• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 7546
  • Last Modified:

Unable to add active directory users permission on ESXI 5.5

Hi,

ESXI 5.5 , added to the domain via Configuration tab > Authentication Services > Properites > Join Domain, this was successful and I can see the computer account in AD.

Turned on relevant services as far as I can tell under Security Profile > services

when I try to add a permission I can only choose users from the local server, I do not see our domain on the list (when I right click on the esxi in vsphere > Add Permission > Add.. > "domain" drop down list > only (server) appears.

Any ideas ?

tHanks.
0
iNc0g
Asked:
iNc0g
  • 2
  • 2
  • 2
  • +2
1 Solution
 
piyushranusriSystem Cloud SpecialistCommented:
could you please check the networking part.

as login to ssh console and ping the domain,nslookup and default gateway.

remove and re join to domain. the behavior you explain this shows the esxi is not in network


please share the output.
0
 
James HIT DirectorCommented:
Try rebooting the host or run: /usr/sbin/services.sh restart
1
 
iNc0gAuthor Commented:
I've SSHed to the ESXI , pinged the DC host name and it translated to the correct IP and has ping.

removed from domain and rejoined which is successful, but still cannot see users from AD when trying to select from the drop down list, only local users.

the ESXI is on the same network as the DC.

I connected to the ESXI which is on another site from the site I am in using vSphere and joined it to the domain, there shouldn't be a difference if I connect to the ESXI from the same network or a different one.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
James HIT DirectorCommented:
Pinging DNS isn't the issue here.
Can you please just restart the services first and then try adding AD users.
0
 
Aaron TomoskySD-WAN SimplifiedCommented:
Did you login to the vcenter server and join IT to the domain? If not, you can only add domain users to local esxi when you connect to local esxi directly.
0
 
piyushranusriSystem Cloud SpecialistCommented:
can you verify these recommended setting are correct at part.
1. http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1003796

and if need to modify pls use nano command

please share the output
0
 
iNc0gAuthor Commented:
The issue has been solved, I don't know if by restarting the services or by waiting until the domain controllers replicate within sites.

Thanks.
0
 
FantomStrykerCommented:
I too had the same issue with adding ESXi hypervisor 5.5 to domain with functional level 2012. What I ended up doing was creating the two groups in AD (case sensitive) "esx admins" (root equivalent) and "esx users" (read only) then joining the hypervisor to the domain using the administrator account. I then SSH into the host and reset the services by running the command "/usr/sbin/services.sh restart". After all that, I noticed that "esx^admins" appeared, but trusted controllers still showed "--". I was able to add the "esx users" to the permissions tab and users were able to use AD credentials to log in. Hope this works for you if its not too late.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 2
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now