Solved

File Server and DC on one server - Unable to change file permissions

Posted on 2013-11-07
3
303 Views
Last Modified: 2013-11-12
I have a server 2008 box that is setup both as a domain controller and as a file server. Everything was running fine until recently. For some reason, any new folder or file created shows up as ready only. I know this isn't best practices, but how do I properly setup file shares with read/write permissions on a 2008 server that is also a DC. I believe the forest level is at 2000.
0
Comment
Question by:First Last
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 39630927
Someone has probbaly enabled this on the Root Share or directory. Right click the root directory, select properties, uncheck Read only, click apply, this will then ask you if you want to apply the configuration to all of the Subfolders and Files click yes.

Also, it is not a good practice to have your file server on a Domain Controller for the simple fact that on a DC it uses the local administrator account as the domain admin account. You will need to have domain admin privlegdes to do any administrative work, but then you are opening your entire domain to users that might not be authorized.


Will.
0
 
LVL 22

Accepted Solution

by:
David Atkin earned 500 total points
ID: 39630942
Hello,

It sounds like the permissions are being inherited from futher up the tree.  If this is in a specific folder, check the security permissions on the parent folder.  Check if permissions are being inherited.

Give your user account or the admin account full controll/ownership over the folders if needed.  Then give the correct user permissions from there.

Check Share permissions as well to make sure that users have full access/modify permissions.  If they have read only permissions on the share then it will override the file security permissions.
0
 
LVL 54

Expert Comment

by:McKnife
ID: 39632129
Could it be simply default Settings not being edited?
->Any share you create has the default share permission everyone:read. Adjust it to everyone: modify. [not to be confused with NTFS perms]
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article demonstrates probably the easiest way to configure domain-wide tier isolation within Active Directory. If you do not know tier isolation read https://technet.microsoft.com/en-us/windows-server-docs/security/securing-privileged-access/s…
Recently, Microsoft released a best-practice guide for securing Active Directory. It's a whopping 300+ pages long. Those of us tasked with securing our company’s databases and systems would, ideally, have time to devote to learning the ins and outs…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Attackers love to prey on accounts that have privileges. Reducing privileged accounts and protecting privileged accounts therefore is paramount. Users, groups, and service accounts need to be protected to help protect the entire Active Directory …

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question