Run commands in a Task Sequence

Hi All,

I am trying to deploy a Windows 7 image to a number of desktops using an OSD Task Sequence. At the end of the Task Sequence after  where it says Install Applications, I have listed a number of packages and run commands but they all fail.

Example Run command 1:

CMD.exe /c /xcopy "\\servername\share\*"  "C:\public\desktop\"

Example Run command 2:

msiexec.exe /I "\\servername\share\msxlparser.msi" /qn

Failing on MDT 2012 & SCCM 2012 SP1.

Note:

On SCCM 2012 I am not installing the Configuration Client as the customer does not want that installed in the image

Is it because of the WinPE environment??

Driving me crazy!!!
Afternoonan
afternoonanAsked:
Who is Participating?
 
afternoonanConnect With a Mentor Author Commented:
Hi All,

Sorted this by copying the files to the local C: drive and then ran the scripts like a dream.

Afternoonan
0
 
afternoonanAuthor Commented:
Just an added bit of information the workstations are not joined the Domain but in a WorkGroup.
0
 
merowingerCommented:
Can you take all the files you're copying into a SCCM package and run the command line within the package? The account running the Actions may has no privileges to the file share,
0
 
afternoonanAuthor Commented:
Found that copying to local C: drive everything worked. No one else came back with that answer.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.