Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1029
  • Last Modified:

Sharepoint 2010 cannot hide field in List "View Item" dialog

The View Item dialog on one of my lists is displaying a field that I need to hide. The field is not included in any of the views, and Manage Content Type is enabled on the list, but the option to hide the field in question is grayed out under Column Settings in Change Content Type Column. I have successfully hidden several other fields in this list. The only difference between those fields and the problem field is that the latter is a calculated field. Does anybody know what the problem might be?
0
dgmoore1
Asked:
dgmoore1
1 Solution
 
Rainer JeschorCommented:
Hi,
you have two options:
you can try to set the field setting through SharePoint designer or you use this Powershell script:
$web = Get-SPWeb https://yoursharepointurl.com/sites/yoursite
$list = $web.Lists["YourListName"]

$field = $list.Fields["YourCalculatedFieldName"]
$field.ShowInDisplayForm = $false
$field.ShowInEditForm = $false
$field.ShowInViewForms = $false
$field.ShowInNewForm = $false
$field.Update($true)
$list.Update($true)

Open in new window


HTH
Rainer
0
 
dgmoore1Author Commented:
Both options sound promising - I have lost network access on my work computer for a couple of days and won't be able to try these until my login problem is fixed. I'll let you know how it goes.

Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now