Solved

Exchange 2010 and wildcard CA

Posted on 2013-11-08
15
1,191 Views
Last Modified: 2014-04-23
Hi Experts,
I have Exchange 2010 SP3 with Godaddy wildcard Certificate "*.domain.com". Certificate is working fine for both outlook anywhere, OWA but some internal user got some certificate pop up for "mail.domain.com" which is external domain name . when I click on view certificate , the certificate untrusted is "Watchguard Fireware Web CA".

I have tried "Set-ClienAceessServer - identity ServerName  -autodiscoverserviceInternalUri "https://mail.domain.com/autodiscover/autodiscover.xml".

but , some internal clients are still looking for "mail.domain.com" via " Fireware Web CA"

Please , advise

Regards,
Zaw Tun Naing
0
Comment
Question by:mikenus
  • 4
  • 3
  • 2
  • +2
15 Comments
 
LVL 15

Expert Comment

by:Jaroslav Mraz
ID: 39633524
Hi,

simply change DNS A records or make internaly DNS A record MAIL.DOMAIN.COM and point it to EXCHANGE internal or external IP.
0
 

Author Comment

by:mikenus
ID: 39635033
Hi Jeremyno,
Thank you for your advise, I have done that.
I created mail.domain.com zone at internal DNS server and created A record pointing to both exchange internal and external IP address.
but, some of the users still have prompt for fireware web CA.

Regards,
Zaw Tun Naing
0
 
LVL 15

Expert Comment

by:Jaroslav Mraz
ID: 39637979
Strange.


this certificate is on webhosting only ? If you have it in exchange plase delete it. And you can also REPAIR button in account section of outlook after changes on exchange.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 39638115
One of the URLs must be wrong, as the clients don't use another host unless they are told to.
Check the full list using my article here: http://semb.ee/hostnames

Simon.
0
 
LVL 37

Expert Comment

by:ArneLovius
ID: 39638199
Your internal DNS should only have your internal addresses.
0
 
LVL 14

Expert Comment

by:Radweld
ID: 39638203
if you have multiple client access servers, it's worth while checking if the correct certificate is installed and more importantly enabled for web services on each client access server. If they differ then this would explain why some work and some don't.  Also check your DHCP is issuing the correct internal DNS servers, if they are correct then run Ipconfig/flushdns on the client that's experiencing the problem to ensure the correct address is resolved.
0
 

Author Comment

by:mikenus
ID: 39715962
Hi
User cert is still poping up to Watch Guard Fireware Web CA? Any more idea?
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39716090
You must have a Watchguard in place and therefore have DNS entries pointing to that, or it is listening on SSL. That isn't an Exchange issue, it is something outside of Exchange getting in the way.

Simon.
0
 

Author Comment

by:mikenus
ID: 39716092
May I know detail about Watchguard in place?
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39717338
It is your network, so you must know if you have a Watchguard device or not.

Simon.
0
 

Author Comment

by:mikenus
ID: 39719480
Hi Simon,
I have watchguard firewall in place in Network. It is a Edge Device for Internal Network
0
 
LVL 37

Expert Comment

by:ArneLovius
ID: 39720634
might be worthwhile checking the hosts file on that users computer, and what DNS servers they are set for
0
 
LVL 14

Expert Comment

by:Radweld
ID: 39721109
Ping Autodiscover.domain.com and if this responds with the ip of the client access server or the load balancer. If it resolves to the firewall then there's your problem.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Public folders data to network share. 8 28
SBS 2011. One user has no X400 email address 4 33
DNS Domain Issues 10 27
exchange, outlook 20 31
Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question