Delete database in Pervasive CC

I have created a database in pervasive control center and I manage to create it but did not have proper permission to the database server

So I granted myself the required permissions and I'm now able to create a database pointing to the database server

But now I want to delete the database I created before I had the proper permission. Now when I try to delete that database I get this error

7004: Genral failure code

Open in new window


Delete database in Pervasive CC
LVL 1
GerhardpetAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Bill BachConnect With a Mentor PresidentCommented:
As I indicated, YES, but it is complicated:
1) Go to the DBNAMES directory.
2) Clone the file using BUTIL -CLONE newfile DBNAMES.CFG
3) Copy the records over using BUTIL -COPY DBNAMES.CFG newfile
4) Open the newfile with the PSQL Function Executor.
5) Read through each record.  When you find one that you want to delete, click the Delete button to remove it.  Be careful not to remove the wrong ones.
6) Exit Function Executor.
7) Rename DBNAMES.CFG to oldfile.
8) Rename newfile to DBNAMES.CFG.
0
 
Bill BachPresidentCommented:
It would be helpful to know exactly which version of PSQL you are running.  

Try going to the server console (i.e. NOT via remote desktop) and do it there, with an Administrator login.  This should have full rights to do what you need.

Essentially, databases are comprised of one or two pieces (depending on the version).  There is a DBName (which is visible in the PCC) and an Engine DSN (which is visible in the ODBC Administrator).  You can always try to delete the two pieces separately, too.
0
 
GerhardpetAuthor Commented:
I'm on Pervasive 10

Yes I have already deleted the Engine DNS in the ODBC admisnistrator.

But I can't delete the database from the PCC. I only have remote desktop access so I will ask the admin to try from the console. It is on a VMWare server.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Bill BachPresidentCommented:
Was that machine updated from PSQLv9?  If so, check for this registry key:
HKLM/Software/Pervasive Software/Utilities Interface/Settings/Restricted Access on WTS Client.  
Be sure that this value is set to 0 (unrestricted).  With this change, you should be able to delete the DBName from the PCC.  If there is a dialog box to ALSO delete the DSN, be sure to uncheck it, as you have already deleted it.
0
 
GerhardpetAuthor Commented:
No it is a new 2012 Windows server and is clean install of psql 10

I checked the registry key and it is already set to 0
0
 
GerhardpetAuthor Commented:
I just has the IT manager login to the console form VMware vSphere and try to delete from there and that not work either. Same error
0
 
Bill BachPresidentCommented:
Could be that something is messed up in the dbnames.cfg file. Your best action is to uninstall, manually delete DBNAMES.CFG if is remains behind, then reinstall. The other option would be a manual hack of the dbnames file, which is not exactly easy.
0
 
GerhardpetAuthor Commented:
I will re-install. Where is the DBNAMES.CFG file located so that I can make sure it does not remain behind?
0
 
Bill BachPresidentCommented:
It is possible to move it after the fact, so it is best to check the current location.  Open the PCC, select Configure Local Engine, then go to the Directories tab.  Last item should be DBNames location.  You can select this entry text, then paste it into a Windows Explorer window to make going there easier.
0
 
GerhardpetAuthor Commented:
Is there a way to tweak the file to fix the issue instead of reinstalling?
0
 
GerhardpetAuthor Commented:
Did I just figure out the easy way to do this?

I renamed the DBNAMES.CFG and then went to another server copied over from that server.

Then deleted the databases from the other server and now I'm able to add new once. No problem.

All works fine
0
 
Bill BachPresidentCommented:
Well, gee -- if I had known you had a second server, I could have suggested that!
0
 
GerhardpetAuthor Commented:
Well I could not have done this without you explaining the DBNAMES.CFG file.

Thank you very much for you help Bill!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.