Solved

Configuring RDP in a workgroup

Posted on 2013-11-08
11
450 Views
Last Modified: 2013-11-09
Hi  experts,

I have and always have run a domain network. Setting up RDP, on Win 7 Pro machines has always been easy both on the LAN and remotely. Using SBS 2008 Standard.

I am trying to help a friend who is using a workgroup and trying to connect from a Win 7 Pro machine to a Win 7 Pro machine, but he is getting the error message:

This computer can't connect to the remote computer. Try connecting again. If the problem persists, contact the administrator.

He currently has Windows Firewall turned off. So, my questions revolve around some of the names that would be put in compared to a domain setup. And, he is an automatically an accepted remote user.

Allow connections from computers running any version of RD is checked.

Here is where I get confused in trying to help.

In my RDP in the computer name: I have server_name.riverside.local

Under user, I have:   riverside\user_name

In his, he has Computer: Office

Under user, he has: Office\user_name (could he use just his user_name?)

That just seems completely different than domain name\user_name (Obviously, his is a workgroup.

I haven't looked at his Advanced settings yet.

Sorry if confusing. I read somewhere that in Workgroups, you don't have to configure RDP?
0
Comment
Question by:Bert2005
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +1
11 Comments
 
LVL 1

Expert Comment

by:Tech Savy
ID: 39635157
Hi there,

Could you please provide me with the IP address of both the machines
 Follow the action plan given below and let me know the results.

1) Are you able to ping to the other machine? Vice versa ?
2) Are you able to access shares to the destination machine ?
3) Is remote desktop enabled on the destination machine ? If not please right-click on computer-->properties -->goto remote tab-->Enable remote desktop from there
4) As it is a workgroup you just have to type the username password of the destination computer to connect with not the username from where you are connecting from.
5) run this command : netstat -a >1.txt & 1.txt
press CTRL+ F --> type 3389 check if you see something like
0.0.0.0:3389 Listening that means the remote desktop port is open.
Note: do this on the destination machine
6)Do you have a router in between ?
7) Also do you have any antivirus installed ?
0
 
LVL 15

Accepted Solution

by:
Skyler Kincaid earned 250 total points
ID: 39635167
This will hopefully be a much more simple setup then reference above:

1. Make sure you have remote desktop enabled. This can be done by right clicking on Computer > selecting Properties > select Remote Settings from the left > make sure the middle option is checked to allow remote connections from any version of Windows. That will enable RDP.

2. When he is connecting to the machine he should then be prompted for username and password. He will need the username and password for an account on that machine. You will also want to leave the domain blank or you can use the computer name of the computer he is connecting to in place of it but, I would just leave it blank.

Let me know if that helps or if you still run into issues!
0
 
LVL 1

Author Comment

by:Bert2005
ID: 39635169
So, basically, he (working with friend so a little difficult on some info), you could insert the computer name and user name on general, click on edit (it would ask anyway), insert username and password and hit connect? Although you don't need username on the original computer.

1. Can ping both ways
2. Can access shares
3. Yes
4. Do you mean computer name and password
5. Did  get zeroes plus 3389
6. No router, just switch.
7. Do have AV installed.

Thanks.
0
PeopleSoft Has Never Been Easier

PeopleSoft Adoption Made Smooth & Simple!

On-The-Job Training Is made Intuitive & Easy With WalkMe's On-Screen Guidance Tool.  Claim Your Free WalkMe Account Now

 
LVL 1

Assisted Solution

by:Tech Savy
Tech Savy earned 250 total points
ID: 39635176
Yes
computername\username then type password in the password field
Note:computername is the destination computer's name
you can get that info by typing the command "hostname" in comand prompt on the destination machine. But most probably thats not required.

from the source machine in the command prompt run this command if you have telnet enabled
telnet destination_computer's_ip-address 3389

Also make sure in the remote tab settings of my computer's properties you check where it says "allow connections from less secure connections"
0
 
LVL 1

Author Comment

by:Bert2005
ID: 39635178
Thanks xKincaidx,

So, we have it enabled.

Can I assume we need to do nothing under Advanced (as I have to with domain)?

So on the General field, put computer destination in computer. Can leave username blank. I am not sure where the domain is, unless you mean domain_name\user_name. Should just leave that blank.

Thanks.
0
 
LVL 1

Author Comment

by:Bert2005
ID: 39635181
Yes, have less secure setting. Let me call him. I apologize that I am not right in front of it. Obviously, I don't have the issue here. :-)

But, points are points, lol. Be back in a few.
0
 
LVL 1

Expert Comment

by:Tech Savy
ID: 39635182
Yes type the ip-address or hostname of the destination in the general field.

You can leave the username field blank if you do not know that at the moment
Just make sure you type in the username and password of destination computer's account
0
 
LVL 1

Author Comment

by:Bert2005
ID: 39635210
Thanks. Will try it. It's funny how some things can be so hard, even though they are quite easy. Just one little thing wrong.
0
 
LVL 11

Expert Comment

by:Manjunath Sullad
ID: 39635983
Remote Desktop is not working means,

please check system properties – remote desktop & select less secure option.

To enable the greyed-out option,please find the below path,change the settings & restart the system.

Click Start, Run. Type GPEDIT.MSC and press Enter.

Navigate to:
Computer configuration | Administrative Templates | Windows Components | Remote Desktop Services | Remote Desktop Session Host | Connections
In the right-pane, double-click Allow users to connect remotely using Terminal Services, set it to Not configured.


~ Manju
0
 
LVL 15

Expert Comment

by:Skyler Kincaid
ID: 39636479
You don't need to enter a domain because you are logging into a local user account. Where it says domain\username you just type the username.

That is all that needs to be done.

If it still isn't working then you need to make sure that the username that you are using to log in has administrator rights.
0
 
LVL 1

Author Closing Comment

by:Bert2005
ID: 39636505
Thanks. Ironically, we got in to work just as you sent your post. Very difficult to split points as a lot of the comments were similar trying to get someone as dumb as I to get the solution. :-)

It is a peer to peer so there were no TS. I was doing this over the phone, and I couldn't get him to not put the name of the computer in the computer field AND the username field. I kept telling him what you guys told me; to leave that field blank. But, certainly the computer name isn't a domain anyway. Thanks.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Remote desktop in Win10 - Automatically run an application 3 56
SharpDesk V3.3 Scanning Issue 7 52
HP Laserjet Pro MFP M126nw 3 58
Testing Android Development 4 57
In this article, I'll explain how to setup a Plex Media Server (https://plex.tv/) on a Redhat (Centos) 7 based NAS with screenshots to help those looking for assistance.  What is Plex? If you aren't familiar with Plex, it’s a DLNA media serv…
By default the complete memory dump option is disabled in windows . If we want to enable the complete memory dump for a diagnostic purpose, we have a solution for it. here we are using the registry method to enable this.
This Micro Tutorial will teach you how to change your appearance and customize your Windows 7 interface to your unique preference. This will be demonstrated using Windows 7 operating system.
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum editing capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question