Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Accessing FTP IIS 7.5  server 2008 R2

Posted on 2013-11-10
11
Medium Priority
?
530 Views
Last Modified: 2013-12-13
I have FTP working on Server 2008 R2 server using IIS 7.5. I could not get it to work through a  Sonicwall firewall. I can connect and authenticate but not access files in the directory. For now, I setup a site to site VPN. Even with VPN, I still cannot access the directory.

I turned off the Windows firewall and still no luck. It only works on the local area network.

Ideally I do not want to use a site to site vpn but for now I will do whatever I have to do to get it working
0
Comment
Question by:ajdratch
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 3
  • +1
11 Comments
 
LVL 12

Expert Comment

by:Gregory Miller
ID: 39637565
Are you using Passive or Active port allocation? If you have Passive mode enabled, you may need to tell the firewall to open additional ports. If this is not possible, set the FTP server to operate in Active mode which only uses port 21 & 20.

For more details:
http://slacksite.com/other/ftp.html
0
 

Author Comment

by:ajdratch
ID: 39637571
I cannot find where to make it passive or active in IIS 7.5, I would like to make it active mode so I only have to worry about the two ports.

Either way, it should work with a site to site vpn shouldn't it?
0
 
LVL 12

Expert Comment

by:Gregory Miller
ID: 39637586
I do not have access to an IIS 7.5 to give instructions. I did however do some quick searches and found that you need to specify the ports for the Dynamic settings which may help you to set your firewall properly.

http://www.iis.net/learn/publish/using-the-ftp-service/configuring-ftp-firewall-settings-in-iis-7
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 

Author Comment

by:ajdratch
ID: 39637617
Followed the instructions in that link and still no luck. I have no idea why it works on the local network but not through the VPN.

Any other free or inexpensive options for an FTP server. I don't care much for Filezilla
0
 
LVL 12

Expert Comment

by:Gregory Miller
ID: 39637620
VPN is not a bridge for all traffic and you would still need to enable the port range on the firewall. Does the sonic wall allow you to configure secondary ports on its rules? If so, that is where you would specify the port range you specified in the IIS options to match. The firewall would then allow existing connections on port 21 to also have port xxxxx-zzzzz as well.
0
 
LVL 26

Expert Comment

by:Blue Street Tech
ID: 39638108
Hi ajdratch,

The Public Server Wizard is the best way to allow access on the SonicWALL for FTP. You will see a Wizards link on the top right corner of the UI once you login to the SonicWALL. Once you click on it it will automatically create the necessary NAT Policies, Access Rules and Address Objects and/or Address Services to accomplish this. It will allow you to create custom Address Objects and/or Address Services if need be but SonicWALL already has FTP service predefined.

What is the SonicWALL model and firmware?
0
 

Accepted Solution

by:
ajdratch earned 0 total points
ID: 39638745
Turns out the problem was with the Windows Firewall on the client side.  I turned that off and FTP works.
0
 
LVL 26

Expert Comment

by:Blue Street Tech
ID: 39639308
Glad you were able to get it resolved! Go ahead and select your comment (http:#a39638745) as the answer to close the question.
0
 

Author Closing Comment

by:ajdratch
ID: 39658865
Client firewall needs to be configured or turned off
0
 

Expert Comment

by:OldCharon
ID: 39717130
Thanks for this thread.  Been beating my head against the sonicwall for 2 days now.  Since it worked inside the network with the client firewall on, I figured it had to be the sonicwall.
0
 
LVL 26

Expert Comment

by:Blue Street Tech
ID: 39717782
Terrific!
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
Resolving an irritating Remote Desktop connection that stops your saved credentials from being used.
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question