Solved

RemoteApp can't connect externally through RD Gateway

Posted on 2013-11-11
3
2,362 Views
Last Modified: 2016-03-23
I recently set up Remote Desktop Services on Server 2012.  Everything is working except connecting RemoteApp externally (through RD Gateway).  When connecting to RemoteApp, I get the following error:

RemoteApp Disconnected - Your computer can't connect to the remote computer because an error occurred on the remote computer that you want to connect to. Contact your network administrator for assistance.

I have researched this error and can't seem to figure it out.  I'm using a self-issued certificate.  I've installed the certificates on the client machine and I can connect via Remote Desktop externally without any certificate warnings. If I uncheck "Bypass RD Gateway server for local addresses" then I also see the same error internally. So it must be a configuration or certificate issue in RD Gateway?  We plan to purchase a public certificate, but I wanted to see this all working first.   Would a public cert resolve the issue?  Any suggestions? This is a very basic installation of RDS.  All Remote Desktop roles (except Licensing) are installed a single machine.  Can I use RD Web Access & remoteApp without RD Gateway as we used to do in Server 2008?
0
Comment
Question by:robinsonbud
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 1

Expert Comment

by:Ryan Mangan
ID: 40140777
The issue you are seeing is because you are using self assigned certificates.

you can test this by disabling certificate authentication for test purposes:

use the following PowerShell Cmdlets to do this:

Set-RDSessionCollectionConfiguration –CollectionName QuickSessionCollection -CustomRdpProperty “authentication level:i:0”

Once you are finished testing use the following cmdlets to reset this:

Set-RDSessionCollectionConfiguration –CollectionName QuickSessionCollection -CustomRdpProperty “"

Have a look at the following article: http://ryanmangansitblog.com/2013/03/10/configuring-rds-2012-certificates-and-sso/ 

Best regards,

Ryan
0
 

Accepted Solution

by:
robinsonbud earned 0 total points
ID: 40142607
I resolved this a long time ago.  The problem is that RDP client 8.0 doesn't work properly with the Remote Desktop gateway.  The solution is to remove RDP client 8.0, reverting to the previous version.  The way to do that is to remove it in Windows Updates.  You need to remove KB2592687.  So if you remove this update, then you will revert back to the previous version, and, voila, RDP now connects without the above error!  This was some time ago, so I'm not sure if Microsoft has fixed this issue or if there's now a better solution.  Anyone care to update this?  I'll see if I can get a response from Microsoft.
0
 

Author Closing Comment

by:robinsonbud
ID: 41519043
solution
0

Featured Post

Does Your Cloud Backup Use Blockchain Technology?

Blockchain technology has already revolutionized finance thanks to Bitcoin. Now it's disrupting other areas, including the realm of data protection. Learn how blockchain is now being used to authenticate backup files and keep them safe from hackers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The following article is comprised of the pearls we have garnered deploying virtualization solutions since Virtual Server 2005 and subsequent 2008 RTM+ Hyper-V in standalone and clustered environments.
The reason that corporations and businesses use Windows servers is because it supports custom modifications to adapt to the business and what it needs. Most individual users won’t need such powerful options. Here I’ll explain how you can enable Wind…
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…

626 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question