Solved

Autodiscover Exchange 2013 -- Turn off Connect to proxy servers that have this principal name in their certificate

Posted on 2013-11-11
5
3,064 Views
Last Modified: 2013-11-14
Hi,

I am having issues with Exchange Server 2013. Autodiscover is checking the box (Only Connect To Proxy Servers That Have This Principal Name In Their Certificate). How can i disable this.

I have tried:
Set-OutlookProvider EXPR -CertPrincipalName none

but did not work.
0
Comment
Question by:harbz96
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 14

Expert Comment

by:Radweld
ID: 39641343
You have to specify a principle name otherwise how with the cert work?
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39644516
What is the objective with wanting to disable the function?
If your SSL certificate is for host.example.com then fine. If it is for *.example.com then you can have problems, but usually only with Windows XP clients.

Outline the original issue, not what you believe is the fix.

Simon.
0
 

Author Comment

by:harbz96
ID: 39646125
Hi Simon.

Our certificate is for exchange.domain.com

But our proxy address is mail.domain.local

And it's looking for proxy address in certificate
0
 
LVL 14

Expert Comment

by:Radweld
ID: 39647304
Your certificate must have exchange.domain.com listed as a subject alternative name (SAN) entry or be the principle name (the default name) if the default is something else but contains the san entry you can Set-OutlookProvider EXPR -CertPrincipalName exchange.domain.com
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 39647314
You need to reconfigure Exchange to use your public name everywhere. That includes changing the internal and external host name for OWA, ActiveSync, Outlook Anywhere etc. Use a split DNS system to ensure the name resolution goes the correct place.

There should be no reason to change the OutlookProvider value if you configure the host name in Outlook Anywhere correctly.

Internal server names are not allowed on SSL certificates that expire past November 2014, so the switch to split DNS using the external name needs to happen at some point, you may as well do so for a new implementation.

Simon.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

724 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question