Solved

Help with Cisco 851w DHCP config

Posted on 2013-11-11
4
20 Views
Last Modified: 2016-05-31
Hi,

I am trying to configure a Cisco 851w as a router/switch to use on our local network. Im very new at Cisco configuration so I am just taking it step by step.

At the moment, I have the FastEthernet4 (WAN port) connected to a switch on our local network and configured it with an IP address. I can ping the IP from the local network so that seems to work fine. What I am trying to do now is setup the LAN ports on the router to get an IP address from an existing DHCP server on our network - 192.168.1.202.

When I start up the router, a laptop connected to a LAN port gets a DHCP IP, briefly, but then drops it again by the time the router seems to have finished it bootup.

I have added the config below, if there is any advice or pointer you can give it will be greatly appreciated.

Thank you,

Pieter

Current configuration : 3130 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PastaExpressII
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
no logging console
enable secret 5 $1$1da5$klSCD3sRUPu/ba7s6kYUe.
enable password
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-1601887241
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1601887241
 revocation-check none
 rsakeypair TP-self-signed-1601887241
!
!
crypto pki certificate chain TP-self-signed-1601887241
 certificate self-signed 01
  30820266 308201CF A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31363031 38383732 3431301E 170D3038 31313034 30313032
  32345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 36303138
  38373234 3130819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100DE3B 3628278C 864171C6 3E98E60A 267E0A31 5716CE8D 46DF108E AA3056BC
  63ECC758 3A50BBC3 AA3BF94E 8C139A5C 6F0560B6 8F08972D 505F2456 F64E59DD
  22B4759E 2FCD1954 D3DADDEE 9DB013A1 19C47A1C D7C5E8D6 7FA90751 0F2DA24A
  9FD6A532 610D89CB 457CBCC6 5C27CEDE 8958E556 3366305B B977EC03 B6BBB129
  38D50203 010001A3 818D3081 8A300F06 03551D13 0101FF04 05300301 01FF3037
  0603551D 11043030 2E822C50 61737461 45787072 65737349 492E6E65 74776F72
  6B696E6E 6F766174 696F6E73 6B616275 6C2E6C6F 63616C30 1F060355 1D230418
  30168014 246C8205 41090C6F F8059CED DB8BD172 0F794F33 301D0603 551D0E04
  16041424 6C820541 090C6FF8 059CEDDB 8BD1720F 794F3330 0D06092A 864886F7
  0D010104 05000381 8100540F 4F6F4548 17DDBDC2 9BDFFE06 6F2022AE 1432DAEC
  1087DB49 1B9D1768 2299732D AA32FA00 59309421 64497616 C4919CED B41A08D4
  6D1FDEE8 F8A67862 1268935F 069DD605 B6E4E4B8 7F2E6816 326D11DA 37B16C40
  6023D791 397B5F54 541C9EB4 1EB70B0F 6A442356 8D01F02F 493AA88B E3724D96
  8C3B1E8E 8D62B6B1 DB67
        quit
dot11 syslog
no ip routing
ip dhcp relay information trust-all
!
!
no ip cef
no ip domain lookup
ip domain name mydomain.local
ip name-server 192.168.1.202
ip name-server 4.2.2.2
!
!
!
username admin privilege 15 password 0
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 ip address 192.168.1.210 255.255.224.0
 ip helper-address 192.168.1.202
 no ip route-cache
 duplex auto
 speed auto
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 shutdown
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
!
interface Vlan1
 no ip address
 no ip route-cache
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 password systemax32
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
end
0
Comment
Question by:ppdevries
4 Comments
 
LVL 20

Accepted Solution

by:
rauenpc earned 250 total points
Comment Utility
the helper-address needs to be configured on the interface you expect to receive DHCP requests. If you have clients connected to ports 1-4 that need to obtain DHCP addresses, you would put the helper address on interface vlan 1. Fa4 also needs to have an address configured as well as vlan 1, and these addresses need to be routable in your network so you might need to put a static address on your lan.

So let's say you configured vlan 1 with IP 192.168.50.1/24. You would then configure a route in you lan that says to get to 192.168.50.0/24 use the next hop of 192.168.1.210. Put the helper address on vlan 1, and configure the 192.168.50.0/24 DHCP scope on your server and life should be good.

If, however, you are expecting to have clients receive DHCP addresses from the same pool that the rest of your LAN is getting, you would have to essentially turn the router into a bridge.
0
 

Author Comment

by:ppdevries
Comment Utility
My apologies for the delay in getting back to you. Thank you for the feedback. I think what I basically want to do at this stage is turn the router into a bridge as you mentioned.

Any advice in that direction?
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now