Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Outlook 2013 Out of Office Server Unavailable

Posted on 2013-11-12
16
1,708 Views
Last Modified: 2014-01-07
Hi im running a SBS 2011 environment with a SSL certificate and have internal and external users who are using Outlook Anywhere to connect to Exchange..

When they are online are working ok with emails but try and turn on the out off office they get a message to say the server is unavailable?

I have looked into it a bit and it may be related to the autodiscover of the DNS but this has been setup correctly as far as I can see?

Is there anything else I can test and keen to get this working correctly.

Many thanks
0
Comment
Question by:RedDoorSupplies
  • 8
  • 4
  • 2
  • +1
16 Comments
 
LVL 15

Expert Comment

by:MarkMichael
ID: 39641961
Run this from Powershell

Get-WebServicesVirtualDirectory | fl name, *url*

Check that the URL for Web Services is pointing to the correct addresses which are also match the names on your certificate:

eg. https://mail.domain.com/EWS/Exchange.asmx
0
 

Author Comment

by:RedDoorSupplies
ID: 39644345
Hi thanks for that I have run the command and all seems ok for the Internal and External URLS
I have got https://remote.domainname.com/ews/exchange.asmx

The Internal by pass is set to https://servername.domain/ews/exchange.asmx

The remote.domainname.com for the above is the same as on my SSL certificate.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39644519
You said that Autodiscover is setup correctly, but you haven't outlined how it was done.
Unless the SSL certificate is a UC type, with Autodiscover.example.com as an additional name you need to create an additional SRV record in your public DNS for things to work.

Simon.
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 

Author Comment

by:RedDoorSupplies
ID: 39644547
Hi thanks.

As its a SBS certificate you can only create remote.domainname.com on the certificate I believe, as its done in the wizard its creates the answer file if you like for you.

When I say I have setup autodiscover what I mean is I have an a record for autodiscover that points to the correct IP address.

Do I need to change something to get this to work then?

Thanks
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 39645162
If you use the wizard in SBS to create the SSL certificate, then you cannot use the A record method for Autodiscover. The SBS wizard presumes the use of a single name certificate with SRV records.

Therefore you will have to remove the A record in your external DNS and configure an SRV record instead.

http://semb.ee/srv

Simon.
0
 

Author Comment

by:RedDoorSupplies
ID: 39650856
Hi Simon thanks have remove the autodiscover a record and added a SRV but it doesn't seem to have solved the issue.
Is there anyway I can check the SRV record has been correctly setup?

Thanks!
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39651395
Microsoft have a test site at http://exrca.com/ (also linked to from the Exchange toolbox in EMC). That will test the entire process. A common error is to have a wildcard in the domain which means Autodiscover.example.com resolves.

Simon.
0
 

Author Comment

by:RedDoorSupplies
ID: 39651458
Ok thanks have run the autodiscover check and the test was successful with some warning.

When expanding all I can see a few failed checked and some warning.

Would you be able to take a look at the results? Not sure the best way to post the results without giving away too much info!

Thanks
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39653084
You will always get some warnings, because autodiscover attempts a number of different methods, which you probably haven't configured them all.
The system basically goes through a number of steps, what you are looking for is the results against the method that you have configured.

Simon.
0
 
LVL 30

Expert Comment

by:pgm554
ID: 39670633
Bug in the past patch Tuesday causes issues with OL2K13.


   1 Control Panel -> Program and Features
   2 Select View Installed Updates (upper left had side)
   3 Search for KB2837643 and uninstall (you should find 2. remove both)
   4 Search for KB2837618 and uninstall (you should find 2. remove both)

Note: it will ask you to reboot. you do not need to do so right away

    Control Panel -> Mail
    Create a new profile and move any pst, nk2 files, etc over to the new profile

Perform a Windows Update check and select Hide Updates when the 2 that you just removed reappears to prevent it from re-installing later.
0
 

Author Comment

by:RedDoorSupplies
ID: 39683220
Sorry for the delay in getting back to you im just trying the patch removal now.

Cant you remind me how to transfer the nk2 file over, there are no PST's at all as all emails just held on the exchange server.

Thanks
0
 

Author Comment

by:RedDoorSupplies
ID: 39683227
Just to add to Simons comment I have checked the test page again and the

Attempting to test potential Autodiscover URL https://remote.DOMAINNAME.com/Autodiscover/Autodiscover.xml 

Testing of the Autodiscover URL was successful.

So that step seems all ok.

Thanks
0
 
LVL 30

Expert Comment

by:pgm554
ID: 39683770
Don't think you need the nlk as an ost should be recreated when you login to the exchange server.
0
 

Author Comment

by:RedDoorSupplies
ID: 39761757
Hi very sorry for the delay in responding to this I finally got to the error.

After correctly setting up the autodiscover the user was still getting the error.

It turns out that the company has 2 different internet domains which was the issue.

The main one that is on the SSL and used by most users was working fine but the user with the error their default email address was the second domain.

As they are using SBS and can only have 1 domain name im guessing this user will just get this problem, unless I can use the srv record to go from the second domain to the first?

Thanks again!
0
 
LVL 15

Expert Comment

by:MarkMichael
ID: 39762219
Yep, SRV record required to point to other domain would work.
0
 

Author Comment

by:RedDoorSupplies
ID: 39762361
Great thanks Mark will give that a go now.
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
Large Outlook files lead to various unwanted errors and corruption issues. Furthermore, large outlook files can also make Outlook take longer to start-up, search, navigate, and shut-down. So, In this article, i will discuss a method to make your Out…
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

861 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question