Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

iSCSI iniator

Posted on 2013-11-12
15
407 Views
Last Modified: 2014-04-29
Hi,
I have a storage server which i connect my domain controller to using iSCSI. When i first set it up it all went smoothly but recently i have found iSCSI link dropping out. I can log back on to the target but the volumes do not appear exposed by the target. In the past a few reboots seem to have done the trick but that isnt really a very convenient solution. I know the initiator side is working correctly because that machine also connects to another iSCSI target.

I have reassigned the target to the virtual disk on the iSCSI software target and even used IP addresses instead of the IQN but still no difference.

Any suggestions gratefully received
0
Comment
Question by:chrisryan43
  • 6
  • 5
15 Comments
 
LVL 119
ID: 39641970
Software iSCSI is dependent upon good networking, so it you are losing connection with the iSCSI target, do you have issues with the network interface in this computer?
0
 

Author Comment

by:chrisryan43
ID: 39641993
I believe the networking is good (they are physically located next to each other and go through the same switch, pinging reliably etc)

The reason the connection was lost was because the RAID array on the target fell over. HP believe it was a firmware issue on the controller which has now been updated so hopefully shouldnt happen again

I have since rebooted both machines once which didnt resolve the issue and because everything else is working fine i am reluctant to try any more reboots and cause further disruption to the users.

Do you have any other thoughts?

Thanks for your time on this
Chris
0
 
LVL 119

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE^2) earned 500 total points
ID: 39642022
Since you had difficulties, establishing this connection, after a storage outage, I would remove it, and setup again.

iSCSI connections, should re-connect correctly and establish themselves, if storage is available.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 21

Expert Comment

by:RK
ID: 39642067
Hi,

This can be caused when the iSCSI initiator service is not started before the server service.

Is the server service started at the time of issue? if not, start it and see it appears fine. If it works, you need to add a multi-string value for iSCSI  as depends on service  in server service.
0
 

Author Comment

by:chrisryan43
ID: 39645650
Hi,
I had attempted to restart the service but still no joy but i  had some windows updates to apply so gave the server a restart and still nothing. I'm nervous about doing too much on the server side in case i inadvertently erase the RAID. I'm currently in the process of backing everything up elsewhere so that i can play a bit more
0
 

Author Comment

by:chrisryan43
ID: 39647439
Hi,

So this is where i am at.....

I created a new 'Test' virtual disk on the storage server and this then connected fine with the iSCSI initiator. So i then deleted the virtual disk for the one i am having issues with (just within iSCSI software target - not the .vhd file). I also deleted the cbm file just  in case it helped. I then reimported the vhd file back into the software target and it still wont be be seen by the iSCSI initiator. The virtual disk mounts locally fine so i am happy that the file system is  all ok. I am really starting to run out of ideas now
0
 
LVL 119
ID: 39647445
I would escalate a support call to Microsoft on this issue.
0
 

Author Comment

by:chrisryan43
ID: 39647452
*UPDATE* - i just realised that i hadn't added the domain controller back as a device target after reimporting the virtual disk. I have now done it and all is  working. So the delete/import of  the virtual disk (and deleting the cbm file) seems to have fixed it.

Thanks for your time and suggestions on this
0
 
LVL 119
ID: 39647464
Glad it's all working again.
0
 

Author Comment

by:chrisryan43
ID: 40006125
I've requested that this question be closed as follows:

Accepted answer: 0 points for chrisryan43's comment #a39647452

for the following reason:

Closing the question
0
 
LVL 119
ID: 40006126
If my Answers have aided you in this solution, please assign points.
0
 
LVL 119
ID: 40028914
3. Accept http:#a39642022
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Hit router interface limit 7 37
Cisco Prime 2.2 7 33
vSphere Clustering DRS 3 27
DNS server picking up wrong IP address of server 10 56
HOW TO: Connect to the VMware vSphere Hypervisor 6.5 (ESXi 6.5) using the vSphere (HTML5 Web) Host Client 6.5, and perform a simple configuration task of adding a new VMFS 6 datastore.
This article outlines why you need to choose a backup solution that protects your entire environment – including your VMware ESXi and Microsoft Hyper-V virtualization hosts – not just your virtual machines.
Teach the user how to convert virtaul disk file formats and how to rename virtual machine files on datastores. Open vSphere Web Client: Review VM disk settings: Migrate VM to new datastore with a thick provisioned (lazy zeroed) disk format: Rename a…
Teach the user how to configure vSphere clusters to support the VMware FT feature Open vSphere Web Client: Verify vSphere HA is enabled: Verify netowrking for vMotion and FT Logging is in place or create it: Turn On FT for a virtual machine: Verify …

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question