Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Auto Complete in Outlook 2010 not transfering to other servers in the Terminal server farm for the users Roaming profiles

Posted on 2013-11-12
6
Medium Priority
?
1,896 Views
Last Modified: 2013-11-18
I have 5 Terminal servers setup in a farm with load balancing. The users have roaming profiles. The issue I'm having is the users after they have setup there outlook and use it they are not getting there auto complete transfering to the other servers when they try to send an email. There outlook profile transfers with no problem. Opens up and is setup the way it should be with there signature and other settings. Just the auto complete does not transfer from server to server for email addresses. What do I need to do to fix this.
0
Comment
Question by:IT-DKB
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 32

Expert Comment

by:Rodney Barnhardt
ID: 39645540
What version of Outlook? If it is earlier than 2010, it is a NK2 file, which is located in the "%username%\ApppData\Local\Microsoft\" after Microsoft, it depends on the version. However, if the NK2 file is created in any folder other than the "Roaming", it will not move with the user. If you are running Outlook 2010 or later with Exchange 2010 or later, the autocomplete is attached to the profile on the Exchange Server.

http://technet.microsoft.com/en-us/library/cc766489(v=ws.10).aspx
0
 
LVL 47

Expert Comment

by:apache09
ID: 39645978
If you using OUtlook 2010 or later the AutoComplete File is no longer called NK2

Its now called Stream_AutoComplete DAT File

Its often found in:

C:\Users\UserID\AppData\Local\Microsoft\Outlook\RoamCache

Of course this may vary depending on your version of terminal server and how its setup.

However, if you focus getting the stream auto complete to be copied over to the users Stored Profile on the network and downloaded on logon to the other terminal server, you should be okay


Do need to note though, weather or not you do get this dat file to copy across
Users need to be sure to log off the terminal server correctly for it to work

If they just close their session and log onto the next terminal server
their profile will not be copied over to the specified roaming profile location

Then when they log onto the next session, expecting their auto complete to be there, its not going to be


If it were me, I would just explain to the users, that the auto complete is separate and builds up over time. They should not be using the auto complete as an address book as its simply an email address Cache

If its a contact they need, want to save, or access from their outlook
Save it as a Contact its far more dependable and not susceptible to corruption
0
 

Accepted Solution

by:
IT-DKB earned 0 total points
ID: 39646136
Hi Apahce09, What would be the best way to setup the file to copy over to the users roaming profile.
0
Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

 
LVL 47

Expert Comment

by:apache09
ID: 39646207
Id first look in the users saved roaming profile location and see if its being copied there already.

If its not part of the profile being saved, I suppose you cold create a Bat file to copy it over

But this would get messy

You would need to run the bat file on each terminal server, to copy each users autocomplete dat over to their roaming profile.

Of course once there, if it wasn't part of the original copy, not sure if it would bring it back down to the current users session....Haven't really tried it

Could be easier to have the bat copy over the Stream Auto Complete directly from the Terminal Server to the users profile on the other terminal servers.

But you would still need to set this up on each one and for each user.....
0
 
LVL 47

Expert Comment

by:apache09
ID: 39646234
Think The wrong answer may have been selected
0
 

Author Closing Comment

by:IT-DKB
ID: 39656006
Good instructions.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this step by step procedure, you will come to know the details of creating an Outlook meeting in 2007, 2010, 2013 & 2016.
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question