[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Exchange 2010 VSS Replica Writer Errors 2008 R2

Posted on 2013-11-12
2
Medium Priority
?
1,405 Views
Last Modified: 2013-11-16
Hi Folks,  Having issues using Avamar Exchange VSS backup's.

Backup run through of Passive Node in DAG but logs do not truncate and get this error at the end of the backup:

ERROR: Selected writer 'Microsoft Exchange Replica Writer' reported an error!
   - Status: 1 (VSS_WS_STABLE)
   - Writer Failure code: 0x800423f3 (VSS_E_WRITERERROR_RETRYABLE)
0
Comment
Question by:999
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
2 Comments
 
LVL 32

Expert Comment

by:Rodney Barnhardt
ID: 39645652
I have been using Avamar for several years. I ran into a similar problem when we moved to Exchange 2010. From working with Avamar support, I found out that the only way the logs will clear is to backup the active node. The passive node will not clear the logs. Also, with Exchange 2010, unless there is a minimum number of log entries, the logs will not purge for up to 4 days. I had called MS, because on several small databases, even though my backups were successful, the logs were not purging on just those. I believe the link below is the one they sent me:

http://blogs.technet.com/b/timmcmic/archive/2012/03/12/exchange-2010-log-truncation-and-checkpoint-at-log-creation-in-a-database-availability-group.aspx

While I do not remember the VSS error I was getting, it was resolved by making a permission change to the DCOM and adding Network Services. This was done by In Component Services, click Console root, expand Component Services, expand Computers, and then click My Computer. On the Action menu, click Properties. Click on the "COM Security" tab. Select "Edit Defaults" under "Access Permissions". Click Add and Enter "Network Services", then check the "Allow" on Local Access. It should look like this when done:
 Security Changes
0
 
LVL 32

Accepted Solution

by:
Rodney Barnhardt earned 1500 total points
ID: 39645673
BTW, I have not seen any performance problems backing up the active node. Their recommendation was to select "Always" on the Options page, although I have just left it as the active writer.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Have you considered what group policies are backwards and forwards compatible? Windows Active Directory servers and clients use group policy templates to deploy sets of policies within your domain. But, there is a catch to deploying policies. The…
Issue: One Windows 2008 R2 64bit server on the network unable to connect to a buffalo Device (Linkstation) with firmware version 1.56. There are a total of four servers on the network this being one of them. Troubleshooting Steps: Connect via h…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question