Solved

Pix501 configuration:    pix501 inside router  & cable modem

Posted on 2013-11-12
9
633 Views
Last Modified: 2013-11-13
I'm adding  a Pix501 firewall to a small office.   Two computers, but only  one will be behind the firewall (long story, but that is the way it will be).  I've never used Pix501 or firewalls before.   Topology is:
                67.184.154.xx         (192.168.1.1)
Web ------- Cable modem ---------- Router ------------ Computer A (192.168.1.4)
                                     |
                                     |
                                   Pix501  (inside 192.168.53.1; outside 192.168.1.7)
                                     |
                                     |  192.168.53.x
                                     |
                              Computer B    (192.168.53.2)

Open in new window

I have the pix501 installed.   Computer A is working fine.  Router (standard Linksys home router) is working fine.   The router's network is DHCP (192.168.1.xxx);  the Pix501 subnet will only have 1 computer, and just has fixed IP addresses (192.168.53.xxx)

Computer B, which used to work before the Pix501 was installed, now cannot see the router or internet.   I have a serial port access to the Pix501.    I can ping from the Pix501 both inside and outside, so the low-level communications are working.   But no pings will go _through_ the Pix501.    

Computer B is a Mac Mini, connected to Pix501 via ethernet, with the following Network Preferences settings:
    - Network kind: Ethernet
    - Configure IPV4:  Manually  (I'm required to use 192.168.53.xxx)
    - IP address  192.168.53.2
    - Subnet mask:  255.255.255.0
    - Router:  192.168.53.1

I can ping the pix501 from Computer B (and vice versa).    But I cannot ping  the router from Computer B (or vice versa).    I'm not worried about DNS yet: for now I just want to get the low-level pings working from computer B to router.

I must have a flaw in my Pix501 configuration that is preventing  it from relaying pings from inside to outside.  Here it is:


pix501(config)# wr term
Building configuration...
: Saved
:
PIX Version 6.3(1)
interface ethernet0 10baset
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password NJcF4sgutsk553UH encrypted
passwd NJcF4sgutsk553UH encrypted
hostname pix501
domain-name cisco.com
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list 101 permit ip 192.168.53.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list 102 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list 102 permit ip 192.168.53.0 255.255.255.0 192.168.2.0 255.255.255.0
pager lines 24
logging console debugging
logging trap debugging
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside 192.168.53.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 192.168.1.0 255.255.255.0 0 0
nat (inside) 1 192.168.53.0 255.255.255.0 0 0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.52.13 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set xfrmSet3 esp-des esp-md5-hmac
crypto ipsec transform-set xfrmSet4 ah-md5-hmac esp-des
crypto map toRemote 1 ipsec-isakmp
crypto map toRemote 1 match address 102
crypto map toRemote 1 set peer 194.110.195.132
crypto map toRemote 1 set transform-set xfrmSet3 xfrmSet4
crypto map toRemote interface outside
isakmp enable outside
isakmp key ******** address 194.110.195.132 netmask 255.255.255.240 no-xauth no-
config-mode
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption 3des
isakmp policy 1 hash sha
isakmp policy 1 group 2
isakmp policy 1 lifetime 28800
isakmp policy 2 authentication pre-share
isakmp policy 2 encryption 3des
isakmp policy 2 hash md5
isakmp policy 2 group 2
isakmp policy 2 lifetime 28800
isakmp policy 3 authentication pre-share
isakmp policy 3 encryption des
isakmp policy 3 hash md5
isakmp policy 3 group 1
isakmp policy 3 lifetime 28800
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
telnet 192.168.52.0 255.255.255.0 inside
telnet 192.168.1.0 255.255.255.0 inside
telnet 192.168.53.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group myisp request dialout pppoe
vpdn group myisp localname admin
vpdn group myisp ppp authentication pap
vpdn group ISP request dialout pppoe
vpdn group ISP localname admin
vpdn group ISP ppp authentication pap
vpdn username admin password *********
dhcpd auto_config outside
terminal width 80
Cryptochecksum:ea3211f925da521b91b5b17acb50ea15
: end
0
Comment
Question by:Bruce_hotchkiss
  • 5
  • 4
9 Comments
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 39643978
First, get rid of these:
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0

access-list 102 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0

nat (inside) 1 192.168.1.0 255.255.255.0 0 0


The 192.168.1.0 network is not on the inside of the PIX so that might mess things up.

Second, you might want to consider giving the PIX a static address on the outside (makes things easier for my third point).

Third, does you router have a route to the 192.168.1.0 network through the IP address of the PIX?
0
 

Author Comment

by:Bruce_hotchkiss
ID: 39644972
Ernie:  thanks for your suggestions.  In reply:
1) I removed those two access-lists, using the "no access-list" command.
2) I don't know how to give the Pix a static address on the outside .. if you can give me a tip there it would be appreciated.
3) Do you have a typo there?  The 192.168.1.0 subnet is already the "inside" net of the Linksys router.  Are you asking if the router has a route to the 192.168.53.0 subnet (inside the Pix501)?  The answer to that latter question is "no", but I can try.  I access the router via web browser http://www.routerlogin.net/start.htm.   It has a mechanism to create "static routes" .. that must be what I need.  It is asking me for a "gateway IP addr" and a "destination IP addr" ... not sure what those refer to, but I'll try to figure it out.
0
 

Author Comment

by:Bruce_hotchkiss
ID: 39645123
Progress report from author:

a)  The outside IP address of the Pix501 is 192.168.1.7 ... its been that way for a week, and I'm not powering anything off for awhile, so I can probably defer the "static address" (task #2 above) until later.  
b)  I'm working on adding a static route to the Linksys router (task #3 above).   I'm trying various permutations, including:
  - Destination IP =  192.168.53.0   [the Pix501 inside subnet]
  - Subnet mask   = 255.255.255.0
  - Gateway IP     = 192.168.1.7   [the outside IP address of the Pix501]
The above static route, alas, does not permit my pings to go thru the Pix501.  Other permutations of that static route do not work either.
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 39645124
My pleasure. In reply to your reply:

1) Good, we might want to add something again later.
2) The same as on the inside: ip address outisde 192.168.1.x 255.255.255.0 for x use an IP that is outside the DHCP scope ;)
You also need to manually add a default gateway: route outside 0.0.0.0 0.0.0.0 192.168.1.1
3) Typo indeed, i did mean: if the router has a route to the 192.168.53.0 subnet (inside the Pix501). I assume "destination IP addr" would be the subnet you want to route to (192.168.53.0) and "gateway IP addr" would be the outside IP address of the PIX (192.168.1.x).

Let's see where this gets you.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 35

Expert Comment

by:Ernie Beek
ID: 39645147
Ah crosspost.

Pings not going through. Assuming from the inside of the PIX to the internet?

Try adding an access list on the outside:
access-list outside permit icmp any any
access-group outside in interface outside


Also, keep an eye on the (ASDM) logs. That might tell you more of what is going on/wrong.
0
 

Author Comment

by:Bruce_hotchkiss
ID: 39645270
Author:  Partial progress!!!    I've incorporated your latest suggestions:
 - ip address outside ...
 - route outside ...
 - access-list ...
 - access-group ...
The pings I am trying are simply from computer A to computer B (see topology diagram at top).  I am not yet attempting anything in the outside WWW, nor am I attempting to use DNS URLs like www.cnn.com.  So here is what I'm trying:
   computer A> ping 192.168.53.2    [fails: time outs]
   computer B> ping 192.168.1.4  [SUCCESS!]
In other words, computer B behind the pix501 firewall can ping to the outside;  but pings from outside the firewall (from computer A) cannot reach computer B (inside the firewall).   The problem is probably either:
  a) my static route in the Linksys router is erroneous (see 2 posts above)
or
  b) my Pix501 configuration is stopping the incoming pings from crossing the firewall
0
 
LVL 35

Accepted Solution

by:
Ernie Beek earned 500 total points
ID: 39645337
I think that would be b), because that's what firewalls do :)

If you want to be able to get through the firewall to reach 192.168.53.2 we'll need to do some additional configuring. Though you put the PIX there to block traffic to the 192.168.53.2, didn't you? Or just to control the traffic to the 192.168.53.2 and allow only certain ports?

To be able to get to it, let's add the following (we'll need an extra 192.168.1.x address for that, I'll use 192.168.1.5 here):

static (inside,outside) 192.168.1.5 192.168.53.2 netmask 255.255.255.0

This creates a static NAT between those two IP addresses. Now you should be able to ping 192.168.1.5 (which translates to 192.168.53.2). So if you want to be able to reach the 192.168.53.2 on any other port, add a rule to your outside access list.
For example RDP:
access-list outside permit tcp any host 192.168.1.5 eq 3389

Now when you set up an RDP session to 192.168.1.5, you should end up on the 192.168.53.2.
0
 

Author Closing Comment

by:Bruce_hotchkiss
ID: 39645558
Very patient and clear!
0
 

Author Comment

by:Bruce_hotchkiss
ID: 39645565
Ernie:  thanks for all the help.   I've got pings going both ways thru the firewall, and that is what I wanted to accomplish in the short term.

Computer B behind the firewall still cannot access web sites, but that is because I dont have DNS working.  Not sure how to do that ...  but if I cannot figure it out after some research, I'll make a new post on that topic.

PS: This firewall is not to block incoming traffic,  it is to support a (future) VPN from comptuer B to a remote site.
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Suggested Solutions

This story has been written with permission from the scammed victim, a valued client of mine – identity protected by request.
Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now