Solved

Unable to access shares using VPN (L2TP over IPSec )

Posted on 2013-11-13
5
914 Views
Last Modified: 2013-11-27
Hi Could someone tell me how to get a fix for the following issue

I am doing VPN into my network using L2TP over IPSec into the SBS server. I have a Cisco VPN server

It uses different account to connect to the cisco VPN does not use domain accounts
When i try open shares
\\<hostname> i get access denied , user does not have permissions
I researched and added Authenticated Users into the Builtin-->Windows Authenticated Access group (something like that ) ..then it gave me the user account was not found.

As per the netmon trace , its giving me KerberosV5 error and it is passing the VPN account credentials when it tries to access the shares. Thats why it is getting access denied. Is there a way to pass domain credentials instead of passing the VPN account credentials. It takes in this settings automatically. Please share some of your thoughts.

Thanks You.

PS: Able to access shares via FQDN and IP address also was able to map a drive using the net use command
net use z: \\<hostname> /user:domain\username password
Command executed successfully so definitely it is a problem with those vpn account credentials being passed on
0
Comment
Question by:Tech Savy
  • 3
  • 2
5 Comments
 
LVL 77

Expert Comment

by:Rob Williams
ID: 39646384
If the FQDN works then it sounds like the domain suffix is not being added to the host name.  When using a Windows VPN you can do so under the advanced TCP/IP properties of the DNS tab of the NIC configuration for the VPN/PPP virtual adapter, by adding the domain suffix (e.g. mydomain.local) in the "use this domain suffix for this connection".  I don't know that you have this option with the Cisco VPN client, but the Cisco admin should be able to push that out with the deployment package, or VPN DHCP scope options.
0
 
LVL 1

Author Comment

by:Tech Savy
ID: 39646578
I tried putting the DNS suffix for the VPN connectroid but that din't work I will see the options on the VPN server though
0
 
LVL 1

Accepted Solution

by:
Tech Savy earned 0 total points
ID: 39669703
It was caching the cisco vpn credentials we removed the cached credentials from Credential manager from Control panel issue resolved.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 39670488
Thanks for posting your findings rauldeshmukh.
Cheers!
--Rob
0
 
LVL 1

Author Closing Comment

by:Tech Savy
ID: 39680245
Self resolved.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

I’m often asked about newer and larger USB drives connected to SBS2008 and 2011 failing Windows Server Backup vs the older USB drives not failing. As disk space continues to grow and drive technology change SBS2008 and some SBS2011 end up with the f…
You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now