Outlook Error: "The name of the security certificate is invalid or does not match the name of the site."

We set up a new server SBS 2011 Exchange 2010. I have the SSL cert installed but the users are getting this error or pop up in Outlook: "The name of the security certificate is invalid or does not match the name of the site." They can hit Yes or even install the certificate and it will work but every time they login it gives this pop up.  I found this site with a possible solution but I'm not very familiar with the Exchange shell commands and don't want to mess anything up do you think these commands are the solution?

STEP 1:

Exchange 2010 and SBS 2011
(Change the values in red where “EXCHANGE-MAIL” is your internal server name and “mail.publicdomain.co.uk“ is your external server name)

Set-ClientAccessServer -Identity EXCHANGE-MAIL -AutodiscoverServiceInternalUri https://mail.publicdomain.co.uk/autodiscover/autodiscover.xml

Set-WebServicesVirtualDirectory -Identity “EXCHANGE-MAIL\EWS (Default Web Site)” –InternalUrl https://mail.publicdomain.co.uk/EWS/Exchange.asmx

Set-OABVirtualDirectory -Identity “EXCHANGE-MAIL\OAB (Default Web Site)” -InternalURL https://mail.publicdomain.co.uk/OAB

Set-ActiveSyncVirtualDirectory -Identity “EXCHANGE-MAIL\Microsoft-Server-ActiveSync (Default Web Site)” -InternalURL https://mail.publicdomain.co.uk/Microsoft-Server-Activesync

If you plan to use Outlook Anywhere, execute the following command for Exchange 2010 and SBS 2011.

Set-WebServicesVirtualDirectory –Identity ‘EXCHANGE-MAIL\EWS (Default Web Site)’ –ExternalUrl https://mail.publicdomain.co.uk/ews/exchange.asmx

http://www.topitproviders.net/index.php/2013/06/19/outlook-error-the-name-of-the-security-certificate-is-invalid-or-does-not-match-the-name-of-the-site/
LVL 2
Axis52401Security AnalystAsked:
Who is Participating?
 
Simon Butler (Sembee)Connect With a Mentor ConsultantCommented:
The wizards are in the SBS management console.
On the Home tab, under Getting Started. There are five, under the section Connect to the Internet.

Simon.
0
 
I QasmiCommented:
It seems that the virtual directory for OWA , Activesync , EWS , OAB are not correctly set
if that is the reason you need to run these commands and configure the correct path and after that restart the server for the changes to take effect correctly.

Also you can check the event viewer for MSExchange Transport event : 12015 , 10214 , 12016 etc for the certificate errors issues .

take the thumbprint of the certificate you are experiencing errors

also the FQDN for which it is giving errors.

or go to Exchange powershell and enter the command

Get-ExchangeCertificate | fl - Enter

all certificates will be listed

There you can check with thumbprint which certificate is assigned to which FQDN.

Refer my answers in EE :http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_28068630.html
0
 
Simon Butler (Sembee)ConsultantCommented:
Why are you changing the configuration manually?
As this is an SBS server, running the wizards will configure everything for you - no need to run PowerShell commands. What you have now is a confused server.

Run the wizards in the SBS management console to configure the server. If you have an SSL certificate for mail.example.com then you will have to do a custom configuration in the wizard, as it prefers remote.example.com.

Once you have run the configuration wizards, use the install SSL certificate wizard to enable the SSL certificate you have and the errors will go away.

Simon.
0
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

 
Satish AutiSenior System AdministratorCommented:
I agree with Semee, there is no need to manual intervention. Run network wizard to configure the certificate.
0
 
Axis52401Security AnalystAuthor Commented:
I already imported the SSL into exchange. I haven't run any of these commands yet. Are you saying I can use some wizard to fix the problem?
0
 
Simon Butler (Sembee)ConsultantCommented:
You need to run the SBS wizards, which includes the SSL wizard. It will not overwrite your trusted SSL certificate.

The key with SBS is to complete all of the wizards before you start manual modifications. That is how SBS is designed to work. If you don't then you will find things don't work exactly as expected, not just with Exchange, but others parts of SBS.

Simon.
0
 
Axis52401Security AnalystAuthor Commented:
Can you tell me how to start this wizard? Is it under program files is it a command line exe?
0
All Courses

From novice to tech pro — start learning today.