We help IT Professionals succeed at work.

Windows 7 - TrueCrypt Encryption

1,100 Views
Last Modified: 2013-11-14
I have windows 7 pro.  I used TrueCrypt to encrypt the drive. I selected the Preboot Authentication and encrypted the entire drive. Everything has been working for months. During normal booting process, I'm prompted for the Pre-Boot Key.  I enter the Key and Windows 7 will load.  Once at the login, the default password for the user will not work. The default password has not been changed.  I found instructions on how to boot into Mini XP and then run Truecrypt to mount the drive, so I can then reset the user password.  However, I cannot get the automount to detect the boot loader.  These are the  instructions I am following:
- Click Mount Options
- Check the box that reads “Mount partition using system encryption
without pre-boot authentication”
- Enter drive encryption password.
- Your hard drive will now be mounted as a new drive letter (temporarily)

Doesn't work.  

I would appreciate any suggestions.
Comment
Watch Question

Author

Commented:
Does anyone have any suggestions?
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Please explain "doesn't work" - what happens exactly?
Another thing: please describe, what "mini xp" should be.

Author

Commented:
I have a bootable USB Thumb drive with Window's XP - once booted up on the thumb Drive - I launch True-crypt and try to mount the drive.  The current drive has Windows 7 pro installed and encrypted using True Crypt.  

I follow the instructions previously posted to mount the drive.  The error reported is the password is incorrect or it cannot locate the drive.  If I remove the Thumb Drive and boot the system, I'm prompted to enter the encrypted password, it works and continues with  Windows 7 Professional.  

I'm having issue with Windows not the encryption.  If I can use my USB Thumb drive and true-crypt to mount the drive, then I can run a utility to repair or reset the password.
CERTIFIED EXPERT
Distinguished Expert 2019
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
Software and Hardware Engineer
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
@McKnife - thanks for your response
@DaveHowe - I think your suggestion to sata drivers may do to the trick.  I'll try to locate those drives and preform an F6 option to add them as I boot up.  Will report back.
Dave HoweSoftware and Hardware Engineer

Commented:
I did that a few times too - but xp will only accept them from a floppy, so unless you have a usb floppy drive you are hard pressed to do so on modern versions of the pc. Alternatively, you can usually "slipstream" the drivers into the xp (or winpe, more commonly) but there are sata drivers which conflict with other sata drivers (go figure) so I found it more convenient to just go buy a usb floppy drive :)

Author

Commented:
@DaveHowe - well I didn't need the SATA drivers, or my USB Floppy - it was a setting in BIOS.  I have a Dell system - access BIOS and changed the hard drive from ACHI to ATA.  Once I did that, I was able to mount my drive, type in the Encrypted Pre-Boot Password and fix the user password.  Your suggestion put me on the right track.  Thanks.
Dave HoweSoftware and Hardware Engineer

Commented:
yup. that's lucky - many hosts don't have that option, but effectively it does the same thing as the sata driver without the hunt for a disk :)
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.