Solved

Remote site PCs and servers can't reach DMZ zone at main site

Posted on 2013-11-13
11
620 Views
Last Modified: 2014-01-13
Dear experts:

I am a system admin for a small company. We have a remote site with a Cisco ASA 5505 device there. It has very simple setup. it has about 10 security policies and one routing rule.
It has a vpn setup connecting to our main site(let's call local site).

From that site, computers can ping the LAN servers on the Main Site. However, all computers can't ping the servers at DMZ zone. All pings got timed out. Also, all comptuers can't access the web server at the DMZ zone.

I was wondering how could I open the DMZ zone to that remote site.


The following is the running config from the Cisco ASA 5505 firewall.

Result of the command: "show running-config"

: Saved
:
ASA Version 7.2(2)
!
hostname SD-ASA5505
domain-name illuminatinginteriors.com
enable password 8fTlKwQopK/l/KDn encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.10.32.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 66.126.220.214 255.255.255.248
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 8fTlKwQopK/l/KDn encrypted
ftp mode passive
clock summer-time pst recurring
dns server-group DefaultDNS
 domain-name illuminatinginteriors.com
object-group network SD
 network-object 10.10.32.0 255.255.255.0
object-group network BFD
 network-object 10.10.4.0 255.255.252.0
object-group network BFD_DMZ
 description DMZ zone
 network-object 10.0.3.0 255.255.255.224
access-list acl-in extended permit tcp host 10.10.32.5 any eq www
access-list acl-in extended permit tcp host 10.10.32.5 any eq ftp
access-list acl-in extended permit tcp host 10.10.32.6 any eq ftp
access-list acl-in extended permit tcp host 10.10.32.6 any eq www
access-list acl-in extended permit icmp host 10.10.32.6 any traceroute
access-list acl-in extended permit tcp host 10.10.32.3 any eq ftp
access-list acl-in extended permit tcp host 10.10.32.3 any eq www
access-list acl-in extended permit tcp object-group SD object-group BFD eq smtp
access-list acl-in extended permit icmp object-group SD object-group BFD_DMZ
access-list acl-in extended deny tcp any any eq smtp
access-list acl-in extended deny tcp any any eq ftp inactive
access-list acl-in extended deny tcp any any eq www inactive
access-list acl-in extended permit ip any any
access-list acl-out extended permit tcp host 192.208.251.77 host 66.126.220.210 eq 3389
access-list acl-out extended permit tcp any host 66.126.220.211 eq ssh
access-list acl-out extended permit icmp any any echo-reply
access-list acl-out extended deny ip any any
access-list vpn-out extended permit ip 10.10.32.0 255.255.255.0 10.10.24.0 255.255.254.0
access-list vpn-out extended permit ip 10.10.32.0 255.255.255.0 10.10.20.0 255.255.252.0
access-list vpn-out extended permit ip 10.10.32.0 255.255.255.0 10.10.4.0 255.255.252.0
access-list vpn-out remark Created by Jason for permitting traffic from LAN to DMZ at BRADFORD
access-list vpn-out extended permit ip 10.10.32.0 255.255.255.0 10.0.3.0 255.255.255.224
access-list vpn-mpls extended permit ip 10.10.32.0 255.255.255.0 10.10.4.0 255.255.252.0
access-list vpn-mpls extended permit ip 10.10.32.0 255.255.255.0 10.10.20.0 255.255.252.0
access-list vpn-bfd extended permit ip 10.10.32.0 255.255.255.0 10.10.4.0 255.255.252.0 inactive
access-list vpn-bfd extended permit ip 10.10.32.0 255.255.255.0 10.10.20.0 255.255.252.0 inactive
pager lines 24
logging enable
logging console emergencies
logging monitor informational
logging trap emergencies
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 66.126.220.213 netmask 255.255.255.248
nat (inside) 0 access-list vpn-out
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp 66.126.220.210 3389 10.10.32.5 3389 netmask 255.255.255.255
static (inside,outside) tcp 66.126.220.211 ssh 10.10.32.12 ssh netmask 255.255.255.255
access-group acl-in in interface inside
access-group acl-out in interface outside
route outside 0.0.0.0 0.0.0.0 66.126.220.209 1
route outside 10.0.3.0 255.255.255.224 66.126.220.209 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
username mis1 password EoP5HajZ3hySP9kb encrypted
username admin password gtVZGmyQVqXhZX03 encrypted
username thron password KQV7hnlyGGzaz0/Z encrypted
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication serial console LOCAL
aaa authentication ssh console LOCAL
http server enable
http 10.10.20.0 255.255.252.0 inside
http 10.10.32.0 255.255.255.0 inside
http 10.10.4.0 255.255.252.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set mpls esp-aes-256 esp-sha-hmac
crypto map outside_map 30 match address vpn-mpls
crypto map outside_map 30 set peer 66.251.30.102
crypto map outside_map 30 set transform-set mpls
crypto map outside_map 40 match address vpn-bfd
crypto map outside_map 40 set pfs
crypto map outside_map 40 set peer 208.57.242.131
crypto map outside_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 86400
crypto isakmp policy 11
 authentication pre-share
 encryption aes-256
 hash sha
 group 5
 lifetime 3600
tunnel-group 66.251.30.102 type ipsec-l2l
tunnel-group 66.251.30.102 ipsec-attributes
 pre-shared-key *
tunnel-group 208.57.242.131 type ipsec-l2l
tunnel-group 208.57.242.131 ipsec-attributes
 pre-shared-key *
tunnel-group 192.208.251.77 type ipsec-l2l
tunnel-group 192.208.251.77 ipsec-attributes
 pre-shared-key *
telnet 10.10.4.0 255.255.252.0 inside
telnet 10.10.32.0 255.255.255.0 inside
telnet timeout 5
ssh 10.10.32.0 255.255.255.0 inside
ssh 10.10.4.0 255.255.252.0 inside
ssh timeout 10
console timeout 10
management-access inside
dhcpd auto_config outside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
tftp-server inside 10.10.32.12 SD-ASA5505
prompt hostname context
Cryptochecksum:bc6df58c2def773d93ae5781268af793
: end
0
Comment
Question by:Jason Yu
  • 7
  • 4
11 Comments
 

Author Comment

by:Jason Yu
ID: 39646421
Here is the print screen of the configuration from ASDM 5.2 interface.

Any help will be great appreciated! Thanks.
San-Diego-Firewall-Setup.png
0
 
LVL 22

Assisted Solution

by:eeRoot
eeRoot earned 500 total points
ID: 39649872
On the Cisco ASA's you need to verify that there is inpection, as well as the ACL.  See this guide  --> http://www.networkingnut.net/enable-ping-on-the-cisco-asa/

If the above steps don't work, please do some ping tests and see if the ASDM log shows any blocked traffic.
0
 

Author Comment

by:Jason Yu
ID: 39650540
Hi, eeRoot:

Thank you for your help, I followed this post and opened icmp inspection traffic.

From my remote site, I can ping the MPLS interface 10.10.4.1 and other hosts like 10.10.4.34. However, I couldn't ping the firewall's ip 10.10.4.5. Since the DMZ zone is attached to the firewall, I couldn't ping any server on the DMZ zone either.

I called the MPLS/VPN provider and they said "since I can ping from remote network to 10.10.4.1, the routing is good. The problem is my firewall. Could you help me with this?

thanks.
0
 

Author Comment

by:Jason Yu
ID: 39653543
I found the traffic was denied on my firewall.

3      Nov 16 2013      10:01:08      313001      10.10.32.6             Denied ICMP type=8, code=0 from 10.10.32.6 on interface inside
0
 

Author Comment

by:Jason Yu
ID: 39653549
Here is the copy screen of the firewall log file.
firewall-error.jpg
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 22

Expert Comment

by:eeRoot
ID: 39654719
At the time of the failed pings, does the ASDM's log show anything?  There should be an event logged, giving the reason for the dropped traffic.  You may need to set the Logging option for each rule to "informational" for this.
0
 
LVL 22

Expert Comment

by:eeRoot
ID: 39655368
Also, change rule # 6 on the inside interface from allowing traceroute to allowing ICMP.  Pings and trace routing are two functions of ICMP.
0
 

Author Comment

by:Jason Yu
ID: 39657524
HI, eeRoot:

Thank you very much for your update. I appreciate your help.

I enable icmp all service on the remote site's firewall. However I still couldn't ping from the remote site firewall to my main site firewall. From the remote site firewall, I can ping successfully to other LAN ips inside the same network as the main site firewall inside interface.

I think the main site firewall dropped all the ping/traceroute traffic on the firewall/10.10.4.5. So, I created two rules on the inside interface and permit all icmp traffic to and from the internal interface of the firewall. But it's still now successful. Could you please take a look?
the-permit-icmp-rules-for-main-s.png
0
 
LVL 22

Accepted Solution

by:
eeRoot earned 500 total points
ID: 39658159
Can you post screenshots of the interface and NAT configs?  Thanks.
0
 

Author Comment

by:Jason Yu
ID: 39658412
Here is the interfaces:
firewall-interfaces.png
0
 

Author Comment

by:Jason Yu
ID: 39658414
Here are the NAT configs:
NAT-configs-1.png
NAT-configs-2.png
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
Use of TCL script on Cisco devices:  - create file and merge it with running configuration to apply configuration changes
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now