troubleshooting Question

Microsoft Access 2007 Deployment Does Not Work

Avatar of shaunwingin
shaunwinginFlag for South Africa asked on
Microsoft Legacy OSMicrosoft ApplicationsMicrosoft Development
8 Comments2 Solutions576 ViewsLast Modified:
I have prepared a full database system which my client wants as a runtime. I downloaded the tools set containing the Package Solution Wizard and after some time was able to use it confidently.

I beg your patience as the solutions offered were laboriously attempted, fairly complicated, and did not yield a satisfactory result.

This deployment tool only allows one database at a time, so I created one installation package for my front-end, with included files such as a spreadsheet which is an import sample. An Excel license is expected on the client machine. Another package was created for the back-end, and one more for the configuration database.

Installation went smoothly.

I ensured that my Microsoft Office Service Packs were up to date.

On opening the system and logging in, my relink code worked, and I had the interface in front of me. It consists of a tabbed control as my menu, with some tabs having buttons only, some having forms with subforms on them. Only one simple form without subforms, shows correctly.

However all those with subforms were blank. All controls were not visible. (Nothing to do with coding). Tabs with buttons only, were visible. On clicking any button that runs core VBA functions, such as string functions, there were errors such as you see in the "Errors" tab in the attached.

One solution offered to me was that installation references can be in the wrong order (although the development database's are correct). However that cannot be manipulated in a runtime (.accdr) file.

I tried installing to an office 2000, 2003 and 2007 machine which have no Access pre-installed.

Further, permissions was proposed as an issue. Using the Workgroup Administrator, I attempted to assign myself full control as an Administrator on the development front-end. On going into Properties of its shortcut, and clicking "Advanced", brought me to the option "Run as Administrator". But that was greyed out. However I regenerated the packages, reinstalled, and had the same result.

The core references I used were:

-VBA

-MS Acc 12.0 OLB

-OLE Aut

-MSO 12.0 Acc DB Engine Objects Lib


References I included were:

-Microsoft Windows Common Controls 6.0 (SP6)

-Microsoft Office 12.0 Object Library

-Microsoft Excel 12.0 Object Library
ASKER CERTIFIED SOLUTION
Bitsqueezer

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 2 Answers and 8 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 2 Answers and 8 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros