Solved

Exchange Database Compressed State - Uncompressing is failing

Posted on 2013-11-14
7
307 Views
Last Modified: 2013-11-19
My databases dismounted due to a disk space issue. The person attending to it ran disk cleanup and checked the box compress contents to save space.

It took about 3 hours but the 400Gb database file eventually compressed.

Problem is I now can't mount it. And when I untick the compress option I am now on 4th hour the hour glass and being told it is not responding.

Before I tried to uncompress the file, I made a copy of the file on another disk. This copy is not compressed.

Can I force exchange to point to the copy of the database? Moving location then wants to move the file which is not an option. Maybe I can repoint this in ADSI Edit?

Altenratively, should I maybe try the recovery tool?
0
Comment
Question by:xpandit
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
7 Comments
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 39648099
Compressing the database isn't supported and for a file of that size it is going to push the disk subsystem to its limit. Are you sure the copy is decompressed?

If it is, then you need the configuration only switch.

http://technet.microsoft.com/en-us/library/bb124742(v=exchg.80).aspx

This allows you to change the path without moving the file.

However even after doing so, I would suggest a new database is created and the users moved. There is no way of knowing whether there is any damage to the underlying data.

Simon.
0
 
LVL 35

Expert Comment

by:Kimputer
ID: 39648110
If the database was unmounted, and the backup you have is from after that, and the database has not been mounted afterwards, it means the backup is a nice clean version.

Delete the compressed file. Make sure the folder doesn't have the "compress" option ticked. Now copy your backup file back, It will be the original (not compressed) file again. You should be able to mount it now.
0
 

Author Comment

by:xpandit
ID: 39648126
Thanks Simon. Configuration only Swicth? I can't pick it up?

Kimputer - Thanks but I don't have 6 hours to wait while I copy the database.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39648139
I don't understand what you are asking. The configuration only switch is one of the advanced commands for moving the database. It is shown under the parameters of the command in the link I have provided.

You need to get the database size reduced - 400gb is too big for any kind of recovery tasks in a decent time.

Simon.
0
 

Author Comment

by:xpandit
ID: 39648355
Thank you Simon.

I found the switch and it worked. Lots of lessons learnt. :-)
0
 
LVL 35

Expert Comment

by:Kimputer
ID: 39648398
Assigned points to the wrong person! Not that I'm complaining though :)
0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
This video discusses moving either the default database or any database to a new volume.

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question