• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 230
  • Last Modified:

DHCP problem

I have a windows 2003 server and I am having problems connecting through my VPN after a recent router failure. All my IP settings are the same as the old router. The computer all use static IPs, but I am using DHCP for the VPn and the router handles that. Now my computers are connecting but very intermittently. Sometimes they will connect and are able to access the resources and sometime they will connect and they can't access anything. The Ip is 192,168.1.x when they can't access the resources and 100.x when it is working properly, but everytime you connect it is like rolling the dice as to what IP you get. I have tried multiple things and have set the RRAS to a static pool and that fixed the Ip problem but was still unable to access resources. There is no VPn client, we are using Windows
0
active_datacomm
Asked:
active_datacomm
  • 2
1 Solution
 
Justin Merrill, MBACommented:
I like to set DHCP on for the router, but set my own IP address via MAC ID. Once I get an IP address that works, I like to set up my IPv4 IP address to that one through the Network Adapter Settings in Windows. Since DHCP is turned on from the router still, it will try to assign that IP address if your Windows machine is asking for it and it's available.

There is a chance that Windows is not looking at the correct network for an IP address to connect properly through VPN. This would seem to be the answer if you were on a wireless laptop or something. But VPN can be pretty flaky for even a hard wired connection.

Can you try to set up your Internal IP address to the known working IP that succeeds when connecting to the VPN via thh IPv4 IP address of Network Adapter Settings of the Network Adapter you are trying to connect with? Give it a shot and see if that helps. It's best to setup your Internal IP to a MAC address with a lengthy lease time (7 days maybe?) once you are connected properly. That way you are always connecting to the same IP address and there are less chances for IP conflicts on your network.

Also noteworthy: You might have a "Starting at IP 192.168.x.100" range setting in the router setup. Since (typically) DHCP from routers like to count UP from the lowest available IP address, I like to aim high, like 192.168.x.120-150 for example. That way, your "known working IP Address" is far less likely to be in use by other computers on the network.
0
 
active_datacommAuthor Commented:
Sorry it took so long for me to respond, but I solved the problem. Turns out that there was a second modem/router attached to the network that I didn't know about and it was handing out the 192.168.1.x addresses. Disconnected it from the network and made my server the DHCP server. The computers at my VPN locations were then able to get the right IP and access the resources. Thanks for the help.
0
 
active_datacommAuthor Commented:
This was the ultimate solution
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now