Solved

Outlook Anywhere Settings Disappear After Reboot

Posted on 2013-11-14
10
4,809 Views
Last Modified: 2015-05-12
Hello,

We have one user experiencing issues within Outlook 2010. They have an SBS 2008 server. They are trying to use Outlook Anywhere (RPC over HTTP) to connect to the Exchange server from outside of the office. Every time I configure RPC over HTTP in Outlook it works fine until the PC is rebooted and all RPC over HTTP settings are lost and Outlook Anywhere is disabled within the account settings.

I've repaired his OST file and Outlook 2010.  I've also attempted to create a new mail profile but we continue to run into the same issue. We've disabled all add-ins. I also checked Group Policy from the server and I don't see anything that would change the RPC over HTTP settings within Outlook.

Any ideas?

Thanks!
0
Comment
Question by:qualityip
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 58

Expert Comment

by:Cliff Galiher
ID: 39649165
With exchange 2007 (SBS 2008) and Outlook 2010, autodiscover always takes precedence and will overwrite settings just as you describe. So, first guess, autodiscover has been configured incorrectly. Fix that and not only will the PCs not lose settings, but you won't have to manually configure outlook anywhere no mew PCs anymore either.

Testexchangeconnectivity.com can help you teat and find the flaws in your autodiscover setup.
0
 

Author Comment

by:qualityip
ID: 39649327
Autodiscover seems to be configured correctly. I ran the RPC over HTTP and Autodiscover tests at testexchangeconnectivity.com and both passed without any errors.
0
 

Author Comment

by:qualityip
ID: 39649355
Here is what I get when running get-autodiscovervirtualdirectory and get-outlookanywhere.

[PS] C:\Windows\system32>get-autodiscovervirtualdirectory | fl
Creating a new session for implicit remoting of "Get-AutodiscoverVirtualDirectory" command...


RunspaceId                      : 77265d01-0800-4e34-abce-7bcfe9db02e0
Name                            : Autodiscover (Default Web Site)
InternalAuthenticationMethods   : {Basic, Ntlm, WindowsIntegrated, WSSecurity}
ExternalAuthenticationMethods   : {Basic, Ntlm, WindowsIntegrated, WSSecurity}
LiveIdSpNegoAuthentication      : False
WSSecurityAuthentication        : True
LiveIdBasicAuthentication       : False
BasicAuthentication             : True
DigestAuthentication            : False
WindowsAuthentication           : True
MetabasePath                    : IIS://server.domain.local/W3SVC/1/ROOT/Autodiscover
Path                            : C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Autodiscover
ExtendedProtectionTokenChecking : None
ExtendedProtectionFlags         : {}
ExtendedProtectionSPNList       : {}
Server                          : server
InternalUrl                     : https://mail.domain.com/Autodiscover/Autodiscover.xml
ExternalUrl                     : https://mail.domain.com/Autodiscover/Autodiscover.xml
AdminDisplayName                :
ExchangeVersion                 : 0.10 (14.0.100.0)
DistinguishedName               : CN=Autodiscover (Default Web Site),CN=HTTP,CN=Protocols,CN=server,CN=Servers,CN=Exchan
                                  ge Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=First Organizat
                                  ion,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=domain,DC=local
Identity                        : server\Autodiscover (Default Web Site)
Guid                            : d2f08245-dc9d-4fa9-ad73-1f32b4cfa78f
ObjectCategory                  : domain.local/Configuration/Schema/ms-Exch-Auto-Discover-Virtual-Directory
ObjectClass                     : {top, msExchVirtualDirectory, msExchAutoDiscoverVirtualDirectory}
WhenChanged                     : 3/12/2013 11:28:45 AM
WhenCreated                     : 1/14/2013 4:17:59 PM
WhenChangedUTC                  : 3/12/2013 3:28:45 PM
WhenCreatedUTC                  : 1/14/2013 9:17:59 PM
OrganizationId                  :
OriginatingServer               : server.domain.local
IsValid                         : True



[PS] C:\Windows\system32>get-outlookanywhere


RunspaceId                      : 77265d01-0800-4e34-abce-7bcfe9db02e0
ServerName                      : server
SSLOffloading                   : False
ExternalHostname                : mail.domain.com
ClientAuthenticationMethod      : Basic
IISAuthenticationMethods        : {Basic, Ntlm}
XropUrl                         :
MetabasePath                    : IIS://server.domain.local/W3SVC/1/ROOT/Rpc
Path                            : C:\Windows\System32\RpcProxy
ExtendedProtectionTokenChecking : None
ExtendedProtectionFlags         : {}
ExtendedProtectionSPNList       : {}
Server                          : server
AdminDisplayName                :
ExchangeVersion                 : 0.10 (14.0.100.0)
Name                            : Rpc (Default Web Site)
DistinguishedName               : CN=Rpc (Default Web Site),CN=HTTP,CN=Protocols,CN=server,CN=Servers,CN=Exchange Admini
                                  strative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=First Organization,CN=Mi
                                  crosoft Exchange,CN=Services,CN=Configuration,DC=domain,DC=local
Identity                        : server\Rpc (Default Web Site)
Guid                            : 9c251072-5f3d-49f8-af93-8d8683036132
ObjectCategory                  : domain.local/Configuration/Schema/ms-Exch-Rpc-Http-Virtual-Directory
ObjectClass                     : {top, msExchVirtualDirectory, msExchRpcHttpVirtualDirectory}
WhenChanged                     : 3/12/2013 11:50:18 AM
WhenCreated                     : 3/12/2013 11:50:18 AM
WhenChangedUTC                  : 3/12/2013 3:50:18 PM
WhenCreatedUTC                  : 3/12/2013 3:50:18 PM
OrganizationId                  :
OriginatingServer               : server.domain.local
IsValid                         : True

Open in new window


Also, we're using Exchange 2010. I don't see any issues but maybe I'm missing something.

Thanks!
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 58

Expert Comment

by:Cliff Galiher
ID: 39649420
Not that it should matter in this instance, but exchange 2010? SBS 2008 came with exchange 2007. If you added a separate exchange 2010 server, you may have competing services.
0
 

Author Comment

by:qualityip
ID: 39649477
It's actually SBS 2011, sorry!
0
 
LVL 58

Expert Comment

by:Cliff Galiher
ID: 39649573
Okay, so what settings specifically are you having to enable in Outlook that seem to be disappearing. If your autodiscover tests all passed then you shouldn't even be having to make manual changes, no less have those disappear.
0
 

Author Comment

by:qualityip
ID: 39649913
I go to Account Settings -> Select Account -> Change -> More Settings -> Connection

I enable "Connect to Microsoft Exchange using HTTP"

Then I click on "Exchange Proxy Settings"

I enter these values :

Exchange Proxy Address: mail.domain.com
Check "Only connect to proxy servers that have this principal name in their certificate" and enter "msstd:mail.domain.com"
Select Basic Authentication.

After saving these changes the settings disappear completely after rebooting the PC. The settings will also disappear if I wait about 20-30 minutes and check the settings again.

The checkbox for "Connect to Microsoft Exchange using HTTP" is unchecked and all settings are missing.
0
 

Author Comment

by:qualityip
ID: 39656821
bump
0
 

Accepted Solution

by:
CorridorMark earned 500 total points
ID: 40067448
I'm also having this same issue.  Only difference is it's with a hosted exchange service (appriver).  There is only 1 user out of about 300 that we service that's having the issue.

 
I go to Account Settings -> Select Account -> Change -> More Settings -> Connection

I enable "Connect to Microsoft Exchange using HTTP"

Then I click on "Exchange Proxy Settings"

I enter these values :

Exchange Proxy Address: mail.domain.com
Check "Only connect to proxy servers that have this principal name in their certificate" and enter "msstd:mail.domain.com"
Select Basic Authentication.

I have to fix it daily or every time the computer get's restarted.  I'm tried ost repair, new profiles, fresh outlook installs and nothing seems to keep it from reverting back to no settings.  So in that, free bump for qualityip
0
 
LVL 4

Expert Comment

by:mfg1
ID: 40772460
did you ever fix this?
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many people use more than one email account and so it becomes difficult for them to manage them when they use separate accounts,  so, in this article, I have shared an easy way to add Other Mail Accounts in your Google Inbox. It helps to combine all…
For anyone that has accidentally used newSID with Server 2008 R2 (like I did) and hasn't been able to get the server running again because you were unlucky (as I was) and had no backups - I was able to get things working by doing a Registry Hive rec…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question