Solved

Cannot change preferred DNS server from 127.0.0.1 localhost

Posted on 2013-11-14
5
4,877 Views
Last Modified: 2013-11-21
Hello Experts,

I have an irritating little problem...

The preferred DNS server on my (Windows 7) TCP/IPv4 property page is set to 127.0.0.1 (localhost).

I cannot change this setting to another value. Every time I try it reverts back to 127.0.0.1!

Why is this happening?
Did someone set it up this way to look at the hosts file first?

Does anyone know what is going on here?

Thanks!
0
Comment
Question by:Saxitalis
  • 3
  • 2
5 Comments
 
LVL 5

Expert Comment

by:Dontmilkthis
ID: 39649967
The fact that it is automatically changing itself back to 127.0.0.1 despite the fact you're setting it statically sounds like malware activity to me.

have you noticed anything else weird while using the PC?

would be interesting to see if there really is a dns service running on your machine. if you have telnet installed (windows feature) you could try running a telnet to port 53 on your machine... i'd be worried if this works.
telnet 127.0.0.1 53

Open in new window


what's the history of this PC?
have you checked the host file for anomalies? standard hosts file only has 127.0.0.1 as far as I remember.
0
 

Author Comment

by:Saxitalis
ID: 39652021
I think this may have something to do with the OpenDNS service. I was told that this service had been installed on this computer.

According to the documentation... All you have to do to "uninstall" OpenDNS is to change, remove or Obtain DNS Server dynamically on the TCP/IP Properties page...

This is what I have been trying to do but 127.0.0.1 always comes back.

Also, I did scan for Malware and found no viruses.

Could this behavior be caused by the "OpenDNS" service on the computer??

Thanks!
0
 
LVL 5

Accepted Solution

by:
Dontmilkthis earned 500 total points
ID: 39655018
Hi Saxitalis,

I'm not sure if it's openDNS doing this. From a quick google, i'd suggest it's a product called DNSCrypt which encrypts your DNS requests. In order for this service to work it must set your local preferred dns setting to the local host (127.0.0.1) so that all DNS requests go through it.

is there a chance you have DNSCrypt installed?
0
 

Author Comment

by:Saxitalis
ID: 39655314
Nope DNSCrypt is not installed on this machine but thanks for the idea anyway - hmmm
0
 

Author Closing Comment

by:Saxitalis
ID: 39667362
got me looking in the right place - thanks
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Resolve DNS query failed errors for Exchange
When you try to extract and to view the contents of a Microsoft Update Standalone Package (MSU) for Windows Vista, you cannot extract the files from the MSU. Here we are going to explain how to extract those hotfix details without using any third pa…
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

785 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question