Solved

Connecting to DHCP Server

Posted on 2013-11-15
9
1,172 Views
Last Modified: 2014-03-10
I've inherited a Windows network that has a number of locations with Windows 2003 and Windows 2008 servers.  One of the DCs is running Windows 2008 R2 server is also serving DNS and DHCP.

The DHCP environment was showing several servers that had been decommissioned years ago.  I used the tip in http://blogs.technet.com/b/networking/archive/2009/02/27/old-dhcp-servers-appear-in-the-list-of-authorized-servers-after-a-domain-rename.aspx to remove the obsolete servers.

My issue now is that when I'm connected to this particular Windows 2008 R2 server, I can bring up DHCP, but I can't see the locally defined scope.  I can access this server's scope from other systems, and from that perspective, it appears to be operating normally.  The other unusual thing I've noticed is that when accessed locally, instead of the server's name showing at the top of the list, the name of one of the software apps on this server is displayed.  The icon is a server with a red circle and a horizontal white line, which I find to be defined as "DHCP server connected but current user does not have the administrative credentials to manage the server."
The same username can remotely access that server's DHCP setup without problems.

So the questions are (1) why can't I access DHCP locally and (2) why isn't the server name used?
0
Comment
Question by:ITHastings
  • 5
  • 3
9 Comments
 
LVL 21

Expert Comment

by:eeRoot
ID: 39652139
Sounds like you may have at least one old or conflicing DHCP server listed under DHCP's authorized server list.  And also, perhaps there are group policies or local policies restricing which accounts can connect to the DHCP server with admin rights.  On the true DHCP server, launch the DHCP console, right click on "DHCP," and check the "Manage Authorized Servers..." list and make sure no old or rouge DHCP servers exist.  Then check your group and local policies for DHCP admin restrictions.
0
 

Author Comment

by:ITHastings
ID: 39656705
When I started working in this domain, there were two obsolete DHCP servers listed in the authorized server list.  I used ADSIedit to remove them.  I've not come across any group or local policies that would restrict access to the DHCP server.

The same account that can successfully open the DHCP console on the "bad" server remotely cannot do it locally.  I've granted that account membership in the DHCP Administrators group, but that didn't help.

Any other suggestions would be appreciated.
0
 
LVL 21

Expert Comment

by:eeRoot
ID: 39657958
Running "GPResult" on both DHCP servers while logged in with the admin account in question may shed some light on what is happening.  If your admin account is being restricted, the report generated by GPResult should show what group policy or local policy is causing it.
0
 

Author Comment

by:ITHastings
ID: 39659478
The only thing related to DHCP when running GPResult on the two systems is that the id I'm using is a member of the DHCP Administrators group.
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 21

Expert Comment

by:eeRoot
ID: 39661143
The last thing I can think to check is if the MMC console settings have somehow been changed or corrupted.  If you create a new MMC file (start, run, type MMC) and then add the DHCP snap in, can you specify the DHCP server and access it with admin rights?
0
 

Author Comment

by:ITHastings
ID: 39665975
Tried it and get the same result.

I went ahead and reinstalled DHCP on the "obsolete" server and uninstalled DHCP on the new server.  Did a reboot on the new server, went to the \Windows\system32\dhcp folder and removed the files there.  Added the DHCP role back onto the new server.  

Same result.  I can access the new server's DHCP remotely, but not locally.  When I'm local on the new server, I can see DHCP servers in other locations, but I can't see the local scope.
0
 

Accepted Solution

by:
ITHastings earned 0 total points
ID: 39783634
The problem was caused by the presence of a HOSTS file on the server.  The only definition in the file had a different computer name assigned to the IP address of this server.  When I removed the definition, DHCP began working normally when opened locally.
0
 

Author Closing Comment

by:ITHastings
ID: 39793761
No other answer that was submitted worked for this problem.
0
 
LVL 1

Expert Comment

by:Peak-Support
ID: 39916896
Thanks ITHastings. Solved my issue too!
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
Resolve DNS query failed errors for Exchange
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now