Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 437
  • Last Modified:

GPO Proxy Setup

I am wanting to create a proxy setup for specific users so I created a OU, moved computers into this. Created a group policy that would force their lan/proxy connections to connect on 10.2.2.5 port 3128 however when I view the internet connections on the workstations it doesn't appear to be taking effect. It is enforced, not linked and I have authenticated users and domain users in the gp

DC is Windows 2003 32bit
Workstations are Windows 7 64 bit

How can I force the workstations to connect to a proxy and not be tampered with by the user?
0
stlhost
Asked:
stlhost
  • 3
  • 2
2 Solutions
 
MaheshArchitectCommented:
Install GPMC on windows 7 machine
Then create a Policy from win7 machin and apply it to OU containing computers.
In policy, navigate to Computer configuration\administrative templates\windows components\internet explorer and enable below settings.
"Disable Changing Proxy Settings"
Then You can import your current Proxy settings from your machine under User configuration\windows settings\Internet Explorer maintenance\Connection\Connection seetings properties in same GPO.
Now users cannot modify these proxy settings
hope that helps.
0
 
stlhostAuthor Commented:
GPMC wont install due to compatibility issues but I do have RSAT installed that I can edit GP.  The problem is I have no idea if it is working as I have it setup like you said but a user can still change it so its not saving or I'm doing something wrong
0
 
MaheshArchitectCommented:
Please go to affected computer and run rsop.msc or gpresult to export applied GPO configuration.
There you will know if Policy is getting applied or not.
Also go to run windows and enter %logonserver%
This should resolve to netbios name of local authenticating domain controller.
if not, then you need to resolve that problem 1st
In that case check AD site subnet settings and ensure if cleint subnet is mapped to correct AD site.
latly check if DNS settings are percfect on client computer.
The advanced DNS settings should be as per attached screen shot.
OR else it will find difficulty in finding local DC
0
 
stlhostAuthor Commented:
I am using the correct logon server. After I did some research I found out that the domain controller being that it is 2003 and the workstations are windows 7 with IE9 or 10 installed that it won't work and with IE10 installed using RSAT GPMC the internet explorer maintenance is missing now. So in short it doesn't look like I can set a proxy setting via GPO am I correct in assuming this? What would be the alternative
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now