Solved

VMware ESXi 5.5 on HP DL380G5 server, help to expand datastore RAID 5 array on P400

Posted on 2013-11-15
8
5,665 Views
Last Modified: 2016-12-08
We have an HP DL380G5 server with P400 RAID controller, running VMware ESXi v5.5 Hypervisor.  Originally it had (5) 146GB SAS drives connected, as a single RAID 5 array (with 541GB usable).  I plugged in 3 additional 146GB SAS drives.  The goal is to increase the size of the datastore (there is only 1 datastore, called "datastore1").  After doing some research, I increased the size of the array as follows:

     /opt/hp/hpssacli/bin/hpssacli controller slot=1 logicaldrive 1 modify size=max forced

and when displaying the "new" size:

     /opt/hp/hpssacli/bin/hpssacli controller slot=1 show config

it shows:

     logicaldrive 1 (956.9 GB, RAID 5, OK)

I believe this is all good......at least up to this point.  The problem is that (so I'm told) I now need to expand the actual datastore (as it is still showing as 541.75 GB), and I obviously don't know how to properly do it.  

When I look at the partition table:

     partedUtil getptbl /vmfs/devices/disks/vml.0000000000766d686261313a303a30

It returns the ending sector as 1146734896 (which it also shows the ending sector of the "vmfs" partition to be.  I believe this number is incorrect.  I believe it is the OLD ending sector.  I believe the number SHOULD be 1720099632, as I have another identical server (that has had 8 of the same drives.....from its original installation), and it shows 1720099632 as the ending sector.

I'm told that I need to use the following to resize the datastore partition, however, I don't want to type in this command until I know that the actual partition has the sectors that I'm pointing it to:

     /partedUtil resize "/vmfs/devices/disks/vml.0000000000766d686261313a303a30" 3 10229760 1720099632

Then, so I'm told, I need to also do the following:

     vmkfstools --growfs /vmfs/devices/disks/vml.0000000000766d686261313a303a30:3 /vmfs/devices/disks/vml.0000000000766d686261313a303a30:3

and I really don't understand that one, as it appears that the 2 items are actually the same.

Any suggestions?
ScreenShot947.jpg
0
Comment
Question by:adk001
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
8 Comments
 
LVL 120
ID: 39652674
the easiest way is to re-install, or install to USB/SD card, and you will not have this issue.

partedUtil can be tricky to use, and dangerous to use, if you ge the wrong command and syntax.
0
 

Author Comment

by:adk001
ID: 39652690
Please pardon my ignorance, however, I don't understand.  What am I supposed to install to a USB/SD card?  My problem is with the internal RAID array that is supposed to be approximately 956GB, but is only showing as approximately 541GB.  I need to add that additional storage space to the datastore.  Since the maximum number of sectors doesn't show the additional space, I have no way to add those (unseen) sectors to the datastore.
0
 
LVL 42

Expert Comment

by:paulsolov
ID: 39652779
What hancoccka is referring to is blowing away the current datastore and installing a usb drive to install ESXi on.  Afterwards you can use the entire p400 array for the datastore.

Another way to do this is if you to load load the smart start disk in and use is to expand the raid set, typically I perfer have the BBWC installed just in case.  Afterwards you go to the datastore properties and choose to expand the datastore.
0
Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

 

Author Comment

by:adk001
ID: 39652858
The thing is......the logical drive is already expanded (956.9GB).  It even shows as 956.9GB when looking at it via the HP offline RAID management utility (hpssacli) from within VMware (via SSH into the VMware host).  Unfortunately, when looking at VMware's native methods (either command line via partedUtil, or via the VMware Client), it shows up as 541.75GB.  I'm not sure exactly what's screwed up, however, I don't believe it's the P400 RAID.  I believe it properly expanded the RAID array (logical drive / logical volume).  I believe that something in VMware isn't "refreshing", and therefore isn't recognizing that it has expanded.  The idea of running the ESXi host from a USB stick is absurd.  Would it be to regain the storage used (in order for the datastore to have the entire drive)?  If so, it's meaningless, as we're talking about nearly 1TB here.  If a few (certainly a 1-digit number) of GB is "wasted" in the overhead of the host operating system.....it isn't enough to worry about.  By the way, the BBWC is installed & reporting as "OK" (in the hardware status on the client).
0
 
LVL 42

Expert Comment

by:paulsolov
ID: 39652895
You can use this kb to do this.

http://kb.vmware.com/selfservice/documentLinkInt.do?micrositeID=&popup=true&languageId=&externalID=2002461

 What happens when you click on properties of the datastore than manage? On the upper left you should see an option to expand the datastore.
0
 
LVL 120
ID: 39653005
did you expand the RAID, and then Expand the Logical Disk (two operations)

do you have virtual machines on this datastore?

have you got complete backups before we proceed and mangle your partitions?

(this is not easy!).

This was an EE post, where I explained it's used before

http://www.experts-exchange.com/Software/VMWare/Q_28208484.html

(the asker gave up and went for a reinstall!)

So please let me know how you want to proceed, the issue for your information, is that ESXi has been installed on the same disk. e.g. the OS resides on the same disk as the datastore.

also run fdisk, what does it state the size is?
0
 

Accepted Solution

by:
adk001 earned 0 total points
ID: 39657521
as it turns out.........the problem was resolved by rebooting the host (again).  after that, everything works fine!
0
 

Author Closing Comment

by:adk001
ID: 39671100
the reason for accepting my own comment as the solution is that it is the solution.  the other advise wasn't completely relevant as I had already tried what some suggested, and, didn't accept having to completely blow away the RAID array & create a new one.....as that obviously wasn't necessary (by the fact that it all works now, and I actually did NOTHING, other than reboot the host 1 more time).
0

Featured Post

Free eBook: Backup on AWS

Everything you need to know about backup and disaster recovery with AWS, for FREE!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Finding original email is quite difficult due to their duplicates. From this article, you will come to know why multiple duplicates of same emails appear and how to delete duplicate emails from Outlook securely and instantly while vital emails remai…
The business world is becoming increasingly integrated with tech. It’s not just for a select few anymore — but what about if you have a small business? It may be easier than you think to integrate technology into your small business, and it’s likely…
Teach the user how to use configure the vCenter Server storage filters Open vSphere Web Client:  Navigate to vCenter Server Advanced Settings: Add the four vCenter Server storage filters: Review the advanced settings: Modify the values of the four v…
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question