Solved

DNS Server Does not resolve MX Record

Posted on 2013-11-15
5
2,156 Views
Last Modified: 2014-03-03
We have a Windows 2003 DC and Windows 2008 R2 domain.  DNS servers are install on both DCs.  We host our own domain zone and host our own DNS servers.

Using nslookup , the DNS servers only resolve NS and SOA record . They does not resolve MX , PTR and ... records .The result outcome from querying MX record is like below:

domain.com
     primary name server = ns01.domain.com
     responsible mail addr = admin.domain.com
     serial = 24376
     Refresh  = 900
     Retry = 600
     Expire = 86400
     default TTL = 3600

I am able to resolve other external required:

> set q=mx
> google.com

Non-authoritative answer:
google.com      MX preference = 40, mail exchanger = alt3.aspmx.l.google.com
google.com      MX preference = 10, mail exchanger = aspmx.l.google.com
google.com      MX preference = 50, mail exchanger = alt4.aspmx.l.google.com
google.com      MX preference = 30, mail exchanger = alt2.aspmx.l.google.com
google.com      MX preference = 20, mail exchanger = alt1.aspmx.l.google.com

alt3.aspmx.l.google.com internet address = 173.194.76.27
aspmx.l.google.com      internet address = 74.125.129.27
alt4.aspmx.l.google.com internet address = 74.125.131.27
alt2.aspmx.l.google.com internet address = 74.125.137.27
alt1.aspmx.l.google.com internet address = 74.125.142.27

What can I do to resolve this?
0
Comment
Question by:c7oi
5 Comments
 
LVL 56

Expert Comment

by:Cliff Galiher
ID: 39652616
Well, not resolving a PTR record may be nothing PTR records rely on a different zone by design. So if you have not created reverse zones, PTR records will, of course, not resolve.

However, not much is given, a partial zone file or screenshots of the DNS zones and nslookup outputs from failed queries would be helpful.
0
 
LVL 11

Expert Comment

by:Technodweeb
ID: 39652807
If your local domain is the same as your internet domain then your DNS resolution will not forward requests for domains it already knows about. Is your LAN FQDN "domain.com" or do you have it set like "domain.local" or something else that is different?

You might also look at your configurations for the "company.com" zone in the DNS server to verify that is has entries for all of the hosts you want to resolve. If they do not exist, add them.
0
 
LVL 35

Assisted Solution

by:Mahesh
Mahesh earned 500 total points
ID: 39653124
Please do below query against DNS
nslookup <Enter>
set type=all <enter>
yourdomain.com <Enter>

If you could post the output please

also check if .(root) zone is configured on DNS servers, it might block the resolution
Thnaks
0
 

Author Comment

by:c7oi
ID: 39653830
> set type=all
> domain.com
Server:  dc01vm.domain.com
Address:  10.10.101.40

domain.com      internet address = 192.168.1.73
domain.com      internet address = 192.168.1.4
domain.com      internet address = 10.10.101.42
domain.com      internet address = 10.10.101.40
domain.com      internet address = 74.62.220.181
domain.com      internet address = 10.10.101.0
domain.com      internet address = 173.x.x.0
domain.com      internet address = 10.10.101.37
domain.com      internet address = 192.168.1.8
domain.com      nameserver = itserver001.domain.com
domain.com      nameserver = dc02vm.domain.com
domain.com      nameserver = jupiter.domain.com
domain.com      nameserver = dc03vm.domain.com
domain.com      nameserver = dc01vm.domain.com
domain.com
        primary name server = dc01vm.domain.com
        responsible mail addr = administrator.domain.com
        serial  = 461767
        refresh = 900 (15 mins)
        retry   = 600 (10 mins)
        expire  = 86400 (1 day)
        default TTL = 3600 (1 hour)
domain.com      MX preference = 10, mail exchanger = 192.168.1.22
itserver001.domain.com  internet address = 192.168.1.8
dc02vm.domain.com       internet address = 10.10.101.42
jupiter.domain.com      internet address = 192.168.1.4
dc03vm.domain.com       internet address = 192.168.1.73
dc01vm.domain.com       internet address = 10.10.101.40
>
0
 
LVL 35

Accepted Solution

by:
Mahesh earned 500 total points
ID: 39654199
Now you got whatever config you have including MX
You have configured ip address instead of FQDN for MX record.Thats why you are not getting FQDN resolution in case of MX record
In case of windows dns servers, FQDN of mail server is used for MX record and Host (A) record will be configured for that FQDN.
Chek below link
http://searchexchange.techtarget.com/news/1161384/Part-3-How-to-create-an-MX-record
http://searchexchange.techtarget.com/tutorial/Step-7-Changing-your-DNS-servers-MX-record

If you have reverse lookup entries configured for public IP addresses on public dns servers, then just enter public ip address in nslookup
0

Featured Post

Do email signature updates give you a headache?

Do you feel like you are constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

Join & Write a Comment

Resolve DNS query failed errors for Exchange
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
In this Micro Tutorial viewers will learn how to restore single file or folder from Bare Metal backup image of their system. Tutorial shows how to restore files and folders from system backup. Often it is not needed to restore entire system when onl…
This tutorial will walk an individual through the process of configuring basic necessities in order to use the 2010 version of Data Protection Manager. These include storage, agents, and protection jobs. Launch Data Protection Manager from the deskt…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now