Solved

Exchange 2007 SP2 Single Node Cluster (SP3 upgrade failed)

Posted on 2013-11-16
12
872 Views
Last Modified: 2013-11-21
When trying to upgrade a single node Exchange 2007 cluster, I'm erroring out at 63% of configuring the Mailbox Server role with this error:

An error occurred. The error code was 3221684294. The message was The remote server has been paused or is in the process of being started.

I performed the stop-clusteredmailboxserver, took the "cluster group" offline, then ran setup.com /mode:upgrade

I'm not finding much info on how to resolve it but the mailbox databases are down right now. I'm still looking but am in the middle of a downtime window, so if anyone can point me in the right direction quickly, that would be of great help.

OS: Windows 2008 SP2 (on VMware, not sure which version)

Edit: Cleared the excerpt and attached it as a file
ExchangeSetupLog-Excerpt.txt
0
Comment
Question by:DaveQuance
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 3
12 Comments
 

Author Comment

by:DaveQuance
ID: 39653115
I'm wondering if it might be AD related, the only other error I'm finding is (the firewall is disabled on this server as well):

MSExchange ADAccess 2152
Process ExSetup.exe (PID=2524). An remote procedure call (RPC) request to the Microsoft Exchange Active Directory Topology service failed with error 1753 (Error 6d9 from HrGetServersForRole). Make sure that the Remote Procedure Call (RPC) service is running. In addition, make sure that the network ports that are used by RPC are not blocked by a firewall.
0
 
LVL 37

Assisted Solution

by:Mahesh
Mahesh earned 50 total points
ID: 39653159
0
 

Author Comment

by:DaveQuance
ID: 39653163
I'd been looking at the registry related items in posts mentioned in your link and will probably try those soon. I've been apprehensive to reboot the server. I did some DNS checking and restarting of DNS client/server and now when I try the setup, it fails to even get information. Due to my waning window I opened a Microsoft case (figuring it'll take them 2 hours to call me back anyway, so if I haven't figured it out by then I'll welcome the call).

setup.com /mode:upgrade

Welcome to Microsoft Exchange Server 2007 Unattended Setup

Preparing Exchange Setup


 An error occurred when setup was getting the configuration information of the current server. Setup can not continue. Please restart Exchange Server 2007 Setup to retry.


Setup log shows:
[11/16/2013 4:07:20 AM] [0] This machine is part of a Windows failover cluster.
[11/16/2013 4:07:20 AM] [0] The Windows Cluster service encountered an error during function OpenCluster:.
[11/16/2013 4:07:20 AM] [0] There are no more endpoints available from the endpoint mapper
[11/16/2013 4:07:20 AM] [0] An error occurred when setup was getting the configuration information of the current server. Setup can not continue. Please restart Exchange Server 2007 Setup to retry.
[11/16/2013 4:07:20 AM] [0] End of Setup
0
Business Impact of IT Communications

What are the business impacts of how well businesses communicate during an IT incident? Targeting, speed, and transparency all matter. Find out more in this infographic.

 

Author Comment

by:DaveQuance
ID: 39653178
Chimney offloading was already disabled on global (I disabled it on the main interface, but  not the iSCSI one). I also disabled RSS. NetDMA is a registry change though, so I'm holding off on it for now since I think it will require a reboot.

At this point though, I need to get through the new error before I can find out if these changes help.
0
 
LVL 37

Expert Comment

by:Mahesh
ID: 39653180
0
 

Author Comment

by:DaveQuance
ID: 39653184
The errors in those last two links seem to point to a different issue. My current one seems to be cluster related (and the setup being unable to pull configuration information from it).
0
 

Author Comment

by:DaveQuance
ID: 39653239
A reboot got passed the new error but the old is still there (NetDMA is disabled now too). The MS person is on the line now and recommending we do the /UpgradeCMS first. The cluster is being forced to start but it's taking an abnormally long time to start.

I'll update if there is more progress.
0
 

Author Comment

by:DaveQuance
ID: 39653318
When all is done I'll give a every step I performed. Right now I've gotten the mailbox server upgraded but the setup.com /UpgradeCMS is failing (any thoughts?):

[11/16/2013 7:02:43 AM] [2] Unexpected Error
[11/16/2013 7:02:43 AM] [2] Error of unknown type occurred while performing exsetdata operation; the original error code was 0xc1037b45.
[11/16/2013 7:02:43 AM] [2] Ending processing.
[11/16/2013 7:02:43 AM] [1] The following 1 error(s) occurred during task execution:
[11/16/2013 7:02:43 AM] [1] 0.  ErrorRecord: Error of unknown type occurred while performing exsetdata operation; the original error code was 0xc1037b45.
[11/16/2013 7:02:43 AM] [1] 0.  ErrorRecord: Microsoft.Exchange.Management.Tasks.ExsetdataUnknownException: Error of unknown type occurred while performing exsetdata operation; the original error code was 0xc1037b45.
[11/16/2013 7:02:43 AM] [1] Error of unknown type occurred while performing exsetdata operation; the original error code was 0xc1037b45.
[11/16/2013 7:02:43 AM] [1] Setup is halting task execution because of one or more errors in a critical task.
[11/16/2013 7:02:43 AM] [1] Finished executing component tasks.
[11/16/2013 7:02:43 AM] [1] Ending processing.
[11/16/2013 7:02:43 AM] [0] The Exchange Server Setup operation did not complete. For more information, visit http://support.microsoft.com and enter the Error ID.
0
 
LVL 37

Expert Comment

by:Mahesh
ID: 39653366
Sorry friend,
Unable to found solution
please find similar, post resolved by MicroSoft
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_27548078.html
0
 

Author Comment

by:DaveQuance
ID: 39653378
Microsoft has been quiet for a long while... not feeling a great deal of confidence.  My searches are only bringing up references to *creating* clusters, or adding nodes. I haven't found any where the issue occurred during an /upgradeCMS. I might be asking for an escalation soon.

Thank you for your efforts though. Maybe MS will come up with something soon.
0
 

Accepted Solution

by:
DaveQuance earned 0 total points
ID: 39653475
End result is we're uninstalling the Exchange 2007 mailbox server, re-installing (without the CMS since there's only one node and no plan to add another), attaching/mounting databases, and re-homing the users to the "new" databases.

Short of it, MS and I both gave up trying to get the CMS to upgrade. From past experience with mailboxes and re-homing, this will probably be a much faster way since it'll probably take an hour or so to uninstall/reinstall, then 15-25 minutes to wrap the rest up.

Attached are all the steps I went through. While they won't *solve* this issue, they did get through the problem on the mailbox server itself and might prove useful for someone in the future.
0
 

Author Closing Comment

by:DaveQuance
ID: 39665313
Result ended up being a lost cause where a more extreme method was used to accomplish the end goal, so it wasn't *solved* per se. The only progress that did come through, the exact reason it went through is unclear (likely the cluster group remaining online).

I appreciate MaheshPM's efforts. The post I marked, that leads to the Chimney, RSS, etc. references, likely contributed positively to the progress I did make before giving up.
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Export details from Contacts in Exchange 3 35
Exchange Server not available 42 68
Archiving/Deleting Old E-Mail boxes 4 53
MS Exchange 2016 license 5 34
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question