Solved

eclipse will not stop at break points

Posted on 2013-11-16
6
546 Views
Last Modified: 2013-11-17
hi i am running eclipse the below version have it set up for Xdebug in config but cannot seem to get it to stop at a simple hello php program
please see below diagrams i know i am close but just cannot see it
any help would be appreciated


Eclipse for PHP Developers

Version: Helios Service Release 2
Build id: 20110218-0911

versiondebugworkspace
0
Comment
Question by:sydneyguy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
6 Comments
 

Author Comment

by:sydneyguy
ID: 39653996
have the php.ini now set up as it is doing something just not stopping at break points

[XDebug]
zend_extension = "C:\xampp\php\ext\php_xdebug.dll"
xdebug.profiler_append = 0
xdebug.profiler_enable = 1
xdebug.profiler_enable_trigger = 0
xdebug.profiler_output_dir = "C:\xampp\tmp"
xdebug.profiler_output_name = "cachegrind.out.%t-%s"
xdebug.remote_enable = 0
xdebug.remote_handler = "dbgp"
xdebug.remote_host = "127.0.0.1"
xdebug.trace_output_dir = "C:\xampp\tmp"



and  php_xdebug.dll is installed in this dir zend_extension = "C:\xampp\php\ext\php_xdebug.dll"


here is the data in the
cachegrind.out.1384655286-C__xampp_htdocs_phplessons_helloworld_php

version: 1
creator: xdebug 2.2.3
cmd: C:\xampp\htdocs\phplessons\helloworld.php
part: 1
positions: line

events: Time

fl=C:\xampp\htdocs\phplessons\helloworld.php
fn={main}

summary: 0

1 0
0
 

Author Comment

by:sydneyguy
ID: 39654006
funny thing is that if i have a break point selected the system will not run again because the system is still running even though the text appears on the page and displays,
with out the break point the code runs displays perfectly and terminates and is ready to run again.
so its doing something just not allowing to debug and stoping
0
 

Author Comment

by:sydneyguy
ID: 39654046
this is the cam run for ports listened to esp 9000 that the system is hooked up t0

9000
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:sydneyguy
ID: 39654048
its getting to this point and hanging and goes no where except the page is displayed but the debug compile never finishes

debug non compile
0
 

Accepted Solution

by:
sydneyguy earned 0 total points
ID: 39654056
program launching but stopping at 57%
launching waiting for debugsession
0
 

Author Closing Comment

by:sydneyguy
ID: 39655508
it was a port problem and the fact that my net was not connection through ff or ie even though i could ping sites
0

Featured Post

DevOps Toolchain Recommendations

Read this Gartner Research Note and discover how your IT organization can automate and optimize DevOps processes using a toolchain architecture.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There’s a good reason for why it’s called a homepage – it closely resembles that of a physical house and the only real difference is that it’s online. Your website’s homepage is where people come to visit you. It’s the family room of your website wh…
Many old projects have bad code, but the budget doesn't exist to rewrite the codebase. You can update this code to be safer by introducing contemporary input validation, sanitation, and safer database queries.
This video teaches users how to migrate an existing Wordpress website to a new domain.
The viewer will learn how to use and create keystrokes in Netbeans IDE 8.0 for Windows.

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question