• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 511
  • Last Modified:

CentOs disk repair

My CentOS server was acting odd so I rebooted it.  During the boot it said

contains a file system with errors.  Check forced.  Then is says an error occurred during the file system check.  Dropping to a shell:  Give the root password for maintenance.

After putting in my root password I typed ‘fsck -a’ and hit enter.  A few lines cam up saying ‘Inode XXXXXXX was part of the orphaned in ode list. FIXED..  It seems to be running still.. Do I let it run and eventually it will ask me to reboot?

What do I do next?
0
gopher_49
Asked:
gopher_49
1 Solution
 
bevhostCommented:
Yes, let it finish running.  It may complete ok, it may find problems that need you to do something.  Depending on the size of the disk / number of files etc it may take a while.
0
 
gopher_49Author Commented:
It finished and everything seems okay... I went ahead and restored my VM files to a temp drive.. And.. Got a few app level backups ready just in case something bad happens.  I have the VM on an iSCSI volume to the datacenter let me use temporarily.  I'm wondering if their iSCSI taget has issues for I've been running this VM for 2 years and never had an issue until moved it to their iSCSI target.  I'll keep an eye on it and update the ticket tomorrow.
0
 
gheistCommented:
You can always have log for iscsi volume on better volume if in doubt about iscsi's quality. Then it will be log replay and no lengthy fsck in case network disappears.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
xeroxzeroxCommented:
When ctrl+ D option show enter root password if it's not taking password then insert bootable cd of your os..and go to rescue mode...

OR

You can troubleshoot it in SINGLE USER MODE ...when you login in single user mode then
Go to
#vi /etc/fstab

Go to / line & change 0 0 last number in this line... {it show you like- 1 2 or 2 1 or 2 2 then change it to 0 0}
(change all mounting device )
save the file and restart your system..
0
 
gopher_49Author Commented:
I don't think it finished last time it ran.. I rebooted thinking it was hanging.  What are the correct steps to run 'fsck -a' and/or the process to detect and repair.  Don't I have to unmount the disk first?  I have a feeling if I reboot the server it will do what it did in the past...  This being to run 'fsck -a'..  But.. How do I manually run it?
0
 
gheistCommented:
You add boot parameter "single" near the end of kernel line

Usually you get to boot parameter editor by pressing up/dpwn when it tries to boot even if you have timeout 0
Then automatic fsck processes / filesystem and you an manually check the rest...
0
 
gopher_49Author Commented:
So.. I press up/down during the boot process.  Then...  What's the next step?
0
 
gopher_49Author Commented:
Please see attached screenshot.  Is this normal?  Do I just wait?
Screen-Shot-2013-12-02-at-11.33..png
0
 
gopher_49Author Commented:
nevermind.. I ran it with the -y switch and everything is good now.  I just had to wait longer.
0
 
gopher_49Author Commented:
The -y switch is the one to use.. Just be patient and let it finish.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now