Solved

Restricting users saving files on Server 2012 libraries - Remote Desktop services

Posted on 2013-11-18
9
1,189 Views
Last Modified: 2014-11-30
Hi there:
I would like to hide the C drive on my Remote Desktop services running on server 2012.  Also would like to hide libraries and desktop.  Found this article followed it, my libraries are hidden but users can still save at 'libraries\pictures' (see attached).  C drive is not hidden but users cannot save at C.  Would like users not to see C drive and libraries so that they should not clutter my server.  Would be helpful if able to remove 'computer and network icons' from my server  Need help
Followed this article:
http://blogs.msdn.com/b/rds/archive/2011/05/26/how-to-restrict-users-from-accessing-local-drives-of-an-rd-session-host-server-while-using-remoteapp-programs.aspx
EE-submit.docx
0
Comment
Question by:amanzoor
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
9 Comments
 
LVL 41

Accepted Solution

by:
Adam Brown earned 500 total points
ID: 39657723
Libraries are basically just shortcuts to existing folders on the server. To restrict saving files, you would have to find the actual drive path to each actual folder listed in the library and modify the NTFS permissions on that folder to either remove write for authenticated users or deny write to a smaller subset of users.

To hide the C drive, you would need to configure the Group Policy they list so that it functions using Loop Back Policy processing. Hiding the C: drive is a user setting, but the RD Server itself will only see Computer settings by default. Enabling loop back processing will cause users that log in to that server to process user settings in GPOs applied to the OU the computer is in. http://support.microsoft.com/kb/231287 has info on how to do that.
0
 
LVL 4

Author Comment

by:amanzoor
ID: 39658240
Acbrown2010:
Thanks for the reply.  In my case since many users will be logging into the remote desktop server (2012) each user would create their own profile which will have 'Libraries'.  Should I set the NTFS permissions on the 'default folder' and the 'public folder'? so that each new profile made has these permissions set on libraries?
I will set the loop back processing and let you know.
Need help with eliminating 'libraries'.
Thanks
0
 
LVL 41

Expert Comment

by:Adam Brown
ID: 39658537
You could try setting up a mandatory profile that is used when logging in to the server. That will prevent changes from being applied, but I haven't tested to see if it will prevent file saving to libraries.

Alternatively, you could utilize a login script that could set the permissions on the folders in the library when the user logs in. Probably not the best solution, but it's a workaround.
0
Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

 
LVL 4

Author Comment

by:amanzoor
ID: 39659864
The libraries in remote desktop server 2012 are driving me crazy..:) I have removed alomost everything from computer.  The libraries stay unchanged.  On a remote session they appear without any restriction and users can save anywhere choosing 'Documents, Pictures, Music and Videos'  Now I am going to try making a mandatory profile.  Please look at the attached file.
eeLibraries.docx
0
 
LVL 4

Author Comment

by:amanzoor
ID: 39660453
Acbrown;
I used your registry settings from here:
http://www.experts-exchange.com/Software/Server_Software/File_Servers/Active_Directory/Q_26555889.html
they worked and removed the libraries.  But now each remote session is leading me to C:\Users\username\TEMP\pictures and users can save files here....:)
driving me crazy...:)
0
 
LVL 4

Author Comment

by:amanzoor
ID: 39666994
Acbrown:
I did everything I could to make those libraries disappear via any GPO setting of any file, but in the search field if users just highlight computer they can see the libraries folder and can save their.  
-I had removed and put restrictions on C drive but no avail.
-used your registry settings, which removed libraries but I jumped into other issues so I had to revert to putting the registry settings back.
-used WEPCFG script to get rid of libraries on the RD server, users were unable to see libraries but would still search in the search bar.
Need help plz.
microsoft-TS.png
0

Featured Post

Salesforce Made Easy to Use

On-screen guidance at the moment of need enables you & your employees to focus on the core, you can now boost your adoption rates swiftly and simply with one easy tool.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Let’s list some of the technologies that enable smooth teleworking. 
Know what services you can and cannot, should and should not combine on your server.
In this Micro Tutorial viewers will learn how to restore their server from Bare Metal Backup image created with Windows Server Backup feature. As an example Windows 2012R2 is used.
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question