Windows 7 C: drive permissions - file copy problem

Posted on 2013-11-18
Last Modified: 2013-11-18
So with Windows 7, it appears that even a local administrator user account can't copy data to the root of the C: drive...without giving explicit "run" rights as an administrator (when I try to copy something to the root C: I get a window that says "denied" and that I need to provide administrator permissions to copy this file).   However, I have a few mapped network drives from our file server, and if I try to copy a word document (for example) to my root C: from a mapped network drive, I gives me the following error:

Location is not available
P:\ refers to a location that is unavailable.  It could be on a hard drive on this computer, or on a network.  Check to make sure that the disk is properly inserted, or that you are connected to the Internet or your network, and then try again...

But, I am connected properly...and the network drive is still there.  I can copy files from the network drive to my desktop (for example) without any problem.  Why is this happening and how do I "fix" it?
Question by:jbobst
  • 2

Author Comment

ID: 39657682
UPDATE:  so instead of trying to copy a file from the mapped drive letter in windows explorer, I instead opened a window to the same location on the file server, but used a UNC path (\\servername\sharename).  When I copied the file this way, it worked?!  What is the difference here???
LVL 35

Assisted Solution

Mahesh earned 200 total points
ID: 39657714
It might be User Access Control (UAC) issue
Put below code in batch file and run on your machine with elevated command prompt
then reboot your computer and check.The code will disable all UAC on your computer.

reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v ConsentPromptBehaviorAdmin /t REG_DWORD /d 0 /f
reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v ConsentPromptBehaviorUser /t REG_DWORD /d 0 /f
reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v EnableInstallerDetection /t REG_DWORD /d 0 /f
reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v EnableLUA /t REG_DWORD /d 0 /f
reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v EnableSecureUIAPaths /t REG_DWORD /d 0 /f
reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v EnableUIADesktopToggle /t REG_DWORD /d 0 /f
reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v PromptOnSecureDesktop /t REG_DWORD /d 0 /f
reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v ValidateAdminCodeSignatures /t REG_DWORD /d 0 /f

Alternatively, you can disable UAC through control panel \ user accounts \ user account settings
But batch file worked than control panel method for me most of the time.


Author Comment

ID: 39657720
I don't necessarily want to disable UAC, and additionally, there could be some policies being pushed down from the domain server about this.  I am just trying to figure out why this behavior happens.  I can always copy the file to my desktop, then from my desktop, copy it to the root C: drive, or as my update mentioned, I can just use the UNC method.  It just doesn't make sense.
LVL 34

Accepted Solution

Seth Simmons earned 300 total points
ID: 39657862
i totally understand the issue...all about UAC and access tokens

when you are elevated, the drive mappings don't exist so that's why it give that error
if you run a command prompt and do net use you will see the drive mappings
if you run elevated command prompt and to net use you don't see the drive mappings

this explains it a bit more

Programs may be unable to access some network locations after you turn on User Account Control in Windows Vista or newer operating systems

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

First some basics on Windows 7 Backup.  It has 2 components one is a file based backup which is stored in .zip files each zip is split at around 200 Megabytes and there is the Image Backup which is as the name implies a total image of the partition …
By default the complete memory dump option is disabled in windows . If we want to enable the complete memory dump for a diagnostic purpose, we have a solution for it. here we are using the registry method to enable this.
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

25 Experts available now in Live!

Get 1:1 Help Now