Solved

Routing Problems on VM

Posted on 2013-11-18
3
211 Views
Last Modified: 2014-01-21
Hi

I have a Virtual machine configured with windows 2008 R2 and Two NICs in a VMware Environment. The virtual machine has one nic in the Production Network and the other in the DMZ. it is suppose to send traffic destined for 10.*.*.* network to the nic with the gateway of 192.*.*.* how ever after a day or two communication stops. if you reboot the APN in the DMZ and reboot the server communication continues. Any idea?
0
Comment
Question by:Helao Mwapangasha
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 13

Expert Comment

by:SagiEDoc
ID: 39658681
You can add a static route on the server. Open a command window and type:

route add 10.*.*.* MASK 255.0.0.0 192.*.*.*

Clearly do not use "*" if the destination network is 10.51.1.0 use that and the final IP is the actual gateway. Ensure that you only have one gateway entered on one network card. So typically you would have your production network listed. The NIC for the DMZ should have no gateway listed.
0
 
LVL 3

Author Comment

by:Helao Mwapangasha
ID: 39658992
Hi SagiEDoc

I do have routes config. Internal LAN has no Gateway specified and the DMZ Lan has one

Sample route print is attached
routes.PNG
0
 
LVL 13

Accepted Solution

by:
SagiEDoc earned 500 total points
ID: 39659023
I had a similar issue where VM's would loose network. I am not sure if you have a similar setup but this is what I traced the problem to.
I had two network cards (physical) connected to the virtual network. One of these cards was working fine, the other had a misconfigured VLAN. If the virtual network connected to the problem NIC the VM lost connectivity. Once I corrected the problem it all came right. I picked up the problem by looking at the observed ranges of the virtual network (screen shot attached)
I corrected the problem but also to manage this problem in the future I set the Network failover detection to Beacon probing (another screen shot attached.) The default setting is link status which basically means if there is a network cable plugged in and the link status is good then all is well.
By changing this setting it allows VMware to failover the NIC's if there is an issue on the network even if the link status is good. I hope this solves your problem.
1.JPG
2.JPG
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It’s been over a month into 2017, and there is already a sophisticated Gmail phishing email making it rounds. New techniques and tactics, have given hackers a way to authentically impersonate your contacts.How it Works The attack works by targeti…
An article on effective troubleshooting
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question