Solved

Exchange Server Certificate Error SBS 2011

Posted on 2013-11-19
11
262 Views
Last Modified: 2013-12-18
The certificate expired, A new self signed certificate was created, but users get the following error in outlook when connecting to Exchange.

The certificate error is " The name of the security certificate is invalid or does not match the name of the site"
0
Comment
Question by:rmegni
  • 6
  • 3
  • 2
11 Comments
 
LVL 7

Expert Comment

by:valmatic
ID: 39659614
0
 

Author Comment

by:rmegni
ID: 39659696
Can this error not be remedied using a self signed certificate?
0
 
LVL 7

Expert Comment

by:valmatic
ID: 39660295
depends are you using autodiscover to setup the connection, or are you using outlook anywhere? If so i would get a real cert you will have 0 headaches. They aren't that much for the time you will waste screwing with these self signed.
0
Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

 
LVL 6

Expert Comment

by:donnk
ID: 39662281
Use the SBS Manager to fix this.

Goto the network tab, then run the trusted certificate wizard to generate either a self signed (wont work on iphone/ipad outside of the network) or to generate a request to buy a trusted one. I use cheapssl.com as they are loads cheaper than godaddy.
0
 

Author Comment

by:rmegni
ID: 39662930
OK will look at that
0
 

Author Comment

by:rmegni
ID: 39668712
So we imported the new bought certificate, but it still gives the same error when people connect to outlook, is there something we are missing?
0
 
LVL 6

Accepted Solution

by:
donnk earned 500 total points
ID: 39669018
check the name on the certificate matches exactly the internet domain name you have set in the network tab of sbs manager.

Once you ran the wizard and imported the cert, open a web browser on the server and goto this domain name and you should it.
0
 

Author Comment

by:rmegni
ID: 39669884
Ok, for example

Our certificate is
remote.contoso.com, the server name in internet domain name is contoso.com

In our certificate we had these names entered
remote.contoso.com
owa.contoso.com
autodiscover.contoso.com
mail.contoso.com

Autodiscover and owa are being used.
0
 
LVL 6

Expert Comment

by:donnk
ID: 39670026
"remote.contoso.com, the server name in internet domain name is contoso.com"

you mean that both are remote.contoso.com right as you cant have a blank entry for name?

You don't need all those other entries, for example owa is remote.contoso.com/owa

just to be sure your problem is the trusted cert you have used via the wizard isnt showing up when you goto remote.contoso.com. If its not what is if any ?
0
 

Author Comment

by:rmegni
ID: 39675808
ok so when we go to remote.contoso.com the server comes up to a remote login page. The actually IIS page is at mail.contoso.com, so that would be the correct name for the cert then?
0
 

Author Comment

by:rmegni
ID: 39690928
Ok so the internet domain name in the box is contoso.com thats it theres no remote infront of it in internet domain name field
0

Featured Post

Free Tool: Postgres Monitoring System

A PHP and Perl based system to collect and display usage statistics from PostgreSQL databases.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this step by step procedure, you will come to know the details of creating an Outlook meeting in 2007, 2010, 2013 & 2016.
A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
This video discusses moving either the default database or any database to a new volume.
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

792 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question