Redirect base URL to external site on Exchange 2013 server

Hi, I'm trying to redirect the base URL of a website to an external address where the company website is hosted. Currently the www.company.com results in a 403 error, whereas we'd like it to redirect to www.companywebsite.com while still allowing www.company.com/owa, /ecp, etc to remain unaffected. This was very easy with Exchange 2003 and Exchange 2007 servers but, with Exchange 2013 seems to like to keep the IIS setup locked down for the sole use of Exchange.

Can anyone help me with this? The HTTP redirect seems to have no effect even if I disable SSL for the root URL and enable it for all the Exchange components.
gabioszAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

 
Berkson WeinTech FreelancerCommented:
How about editing the index page in the root of the document directory to redirect using a meta refresh tag like this:

<html>
<head>
<meta http-equiv="refresh" content="0; url=http://www.companywebsite.com/">
</head>
<body>
Redirecting
</body>
</html>

Open in new window


That should redirect www.company.com to the real website.  It'll only work with http://www.company.com/ and not www.company.com/page2.html.  In that case you'd need the same thing for page2.html...

Hope this helps.
0
 
gabioszAuthor Commented:
Thanks, but this is the sort of thing i used to be able to do. Now it all ties in with Outlook Web Access, so if I disable SSL required it will stop giving me a 403 error but then redirect to the Outlook Web Access page.
0
 
Berkson WeinTech FreelancerCommented:
Ah, right.  

So you've setup exchange on the www hostname?  You're not to far into this deployment,  would you instead using something like mail.company.com?  Then have www.company.com be a cname to www.companyweb.com.  It's unusual in my opinion to have exchange running on the www hostname.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
gabioszAuthor Commented:
I have been running it like this for years, so it's a bit late to re-arrange it now.  

The email domain is not used for the company website, it's email only so it isn't critical. However, it would be nice to have the www.emaildomain.com redirecting to www.companywebsite.com

I have managed to get the redirect partly working, in as far as the iisstart.htm will redirect, but it won't load this by default.

I have disabled SSL required on the Default Web Site and re-enabled it on the Applications, so they are all secure. Then I tried setting the iisstart.htm to redirect but, it won't load the iisstart.htm unless it's typed manually. It just loads a blank page otherwise.
0
 
gabioszAuthor Commented:
Ok, fixed it by removing the web.config file from the web root which was making a mess of it all.
0

Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
 
gabioszAuthor Commented:
found my own solution
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.