• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 534
  • Last Modified:

IIS HTTP Error 500.19

I am trying to get a .Net web application working on a web server but am having terrible trouble getting server to work.  I am getting error HTTP Error 500.19

This is running on Windows 2008 R2 x 64.  I am getting the following error when trying to load the default web site.  Any thought?
error.jpg
0
canuckconsulting
Asked:
canuckconsulting
1 Solution
 
pateljituCommented:
1. Check "Scenario 7" in this article, it indicates that either IIS is not configured properly or there is corruption in installation:
-- snip --
<remove name="WebServiceHandlerFactory-Integrated"/>”

This usually indicates that ASP.NET is either not installed or has corrupted/incomplete installation because installation of asp.net unlocks that section. Hence if this is the case, one should install asp.net feature from Server Manager (Under Web Server Role in Windows Server 2008 and in Program Features-> Application server in Vista/Windows7). This KB929772 talks about the ASP.NET installation failure reason.
-- snip --

http://blogs.iis.net/webtopics/archive/2010/03/08/troubleshooting-http-500-19-errors-in-iis-7.aspx

On your server open "Server Manager".
1. Add Roles - Confirm if "Web Server (IIS)" is installed
2.  Add Role Services: - Confirm all required component for IIS are installed, especially (Application Development)

http://www.iis.net/learn/install/installing-iis-7/installing-iis-7-and-above-on-windows-server-2008-or-windows-server-2008-r2
0

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now