SBS 2011 - Windows update error

G'day guys,

Newly installed SBS 2011 (Migrated from SBS 2003) comes up with a Windows Update error - Code 8024402C

Weird because WSUS is installed appears to be working fine, I installed updates to the server (first round of updates) and restarted and tried to continue to install updates but then this error occurred.

I tried restarting it and no change. All the required services are running.

Googling came up with people uninstalling WSUS and re-installing it, I would like to avoid that if at all possible.

Also if people would like to have the list of the updates that were installed prior to it breaking I can provide that.

Steve
Steven SwartsOwnerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Imtiaz HashamTechnical Director / IT ConsultantCommented:
Can you try running updates from the MS website?  And check if one of them updates WSUS?
Steven SwartsOwnerAuthor Commented:
It doesn't let me update via the website, unless I'm missing something.

I went to http://windowsupdates.windows.com 

Shows me how to open windows updates via start menu
Jaroslav LatalMSPCommented:
Hi sjswarts,

you can try to run "fix my network wizard"

If it will not help, run SBS BPA:
http://support.microsoft.com/kb/2673284/en-us

If still nothing, repair wsus by following this article:
http://technet.microsoft.com/en-us/library/gg680316.aspx¨


Good luck!

Jarda
Active Protection takes the fight to cryptojacking

While there were several headline-grabbing ransomware attacks during in 2017, another big threat started appearing at the same time that didn’t get the same coverage – illicit cryptomining.

Imtiaz HashamTechnical Director / IT ConsultantCommented:
You need to open Windows Update and click Check Online for updates from Microsoft Update Server.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Steven SwartsOwnerAuthor Commented:
I have already run the "fix my network wizard"

Only found some warnings that weren't a problem, I'm running the BPA now and will see what that finds.

Thanks for the comments
Steven SwartsOwnerAuthor Commented:
Fantastic mate, don't know why they hide it away, but that was all it required. So far its downloading updates right now and hopefully goes to install them soon.

Top stuff
Imtiaz HashamTechnical Director / IT ConsultantCommented:
If WSUS doesn't work after this, you will require to reconfigure WSUS.

Thanks for accepting my answers.
Steven SwartsOwnerAuthor Commented:
I will post back if it works
Steven SwartsOwnerAuthor Commented:
Ok using that method only checks online for the updates, which works but kind of defeats the purpose of WSUS.

I guess I was a bit to early to say this is fixed, as the root problem is still there - somewhere, i'll find you...
Imtiaz HashamTechnical Director / IT ConsultantCommented:
ok, the solution with SBS is not to mess around with WSUS directly.

Go to Small Business Console and use that to manage WSUS
Steven SwartsOwnerAuthor Commented:
Ok that seems to be my issue, is there any way I can default WSUS back to SBS preferred settings?
Steven SwartsOwnerAuthor Commented:
Just hang ten guys, I think I might have remembered all the changes that I did.

It shows up now in SBS Console, so thats a step in the right direction.

I have to remember to use the SBS Console for everything... Argh...

I will post back if it is fixed, need to wait till tonight to restart for some updates to apply.
Imtiaz HashamTechnical Director / IT ConsultantCommented:
Steven SwartsOwnerAuthor Commented:
I might need that later, but for now the updates through SBS 2011 Console (advanced) seem to work. I get a nice green tick on the home tab.

However when I go to scan for updates for the server it errors again - Code 8024402C
Steven SwartsOwnerAuthor Commented:
Ah... I think its the GPO is broken, seeing that the migration from SBS 2003 to SBS 2011, I expected the GPO's to be updated to reflect the new server. How wrong I was.

Thank you @ihasham I believe you have led me to my answer.
Imtiaz HashamTechnical Director / IT ConsultantCommented:
GPOs are fantastic devices to break :)
Steven SwartsOwnerAuthor Commented:
Yes this is a confirmation that the migration had LEFT behind some old GPO's, unfortunately I must have overlooked that part of the step-by-step.

Anyway its happily updating as it should as of now. Thanks to all!!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.