?
Solved

Share Folder rights on Server 2008

Posted on 2013-11-20
3
Medium Priority
?
599 Views
Last Modified: 2013-11-25
I recently installed a new server for a company with Server 2008 R2 installed.  I setup a folder called management, shared it with the management user group.  I added each of the individuals who should have access to this folder to the management group.

The problem is they can only view and edit documents that they create in this folder.  Can someone help me make it so that everyone in the management group and edit, view, change documents in this folder and all sub folders?  My assumption is that their domain user account is fudging up the rights, but I don't have enough time or energy to devote to figuring out Microsoft's oh so great rights management settings.
0
Comment
Question by:pjnutt
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 35

Expert Comment

by:Joseph Daly
ID: 39662619
How are the share settings configured?

How are the NTFS settings configured?

My guess is that you have a conflict between the share and the NTFS permissions.

Try granting full control share access to the Everyone group and then limit access using NTFS permissions.
0
 
LVL 37

Accepted Solution

by:
Mahesh earned 2000 total points
ID: 39662631
Try below
Give management group full control share permissions on folder
Then you take ownership of root shared folder through NTFS advanced security permissions with "Replace owners on subcontainers" option selected.
Then add management group on NTFS permissions with required permissions (Modify) and click apply.
Then from advanced NTFS security permissions window, select "replace all child object permissions with inheritable permissions from this object" checkbox and apply.

Now your top level folder permissions should get applied (inherited) to all sub folders and files without any issue

Thanks
0
 
LVL 22

Expert Comment

by:Nick Rhode
ID: 39662635
Check the permissions for the group and make sure its setup for inheritance.

For the share permissions make sure the group is assigned modify.  Under the properties > security tab add the specific group (if not there already), select the advanced button and on the permissions tab click change permissions and select to replace all child objects inheritable permissions.
0

Featured Post

Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For anyone that has accidentally used newSID with Server 2008 R2 (like I did) and hasn't been able to get the server running again because you were unlucky (as I was) and had no backups - I was able to get things working by doing a Registry Hive rec…
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
In this fourth video of the Xpdf series, we discuss and demonstrate the PDFinfo utility, which retrieves the contents of a PDF's Info Dictionary, as well as some other information, including the page count. We show how to isolate the page count in a…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

718 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question