?
Solved

OWA not working internally

Posted on 2013-11-20
12
Medium Priority
?
475 Views
Last Modified: 2014-05-14
Hi,

I hope someone can help me. I have a situation where OWA does not work internally. OWA is not used internally very often so I can't be sure when/what caused this but it seems to have happened since I updated our soon to expire Exchange certificate.

When browsing to the internal URL (https://exchangeservername/owa) I get the message that the certificate has been revoked. We have two on-premise HT/CA servers and this happens with either of them. OWA works fine externally as does Outlook Anywhere / ActiveSync.

If I run get-exchangecertificate in Powershell it shows all the correct SANs and is enabled for all services but the status shows as "Invalid". To test things, I created a self signed certificate and enabled it for all services. This fixed the problem of internal OWA access but of course broke external access / ActiveSync etc. The intermediate certificate has been installed correctly (I believe).

Does anyone have any ideas? There may be some info I have missed out so just ask if you need to know anything else.

Thanks in advance...
0
Comment
Question by:ishamsi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
12 Comments
 

Author Comment

by:ishamsi
ID: 39662727
Also, in event viewer I get EventID - 12014:

Microsoft Exchange could not find a certificate that contains the domain name localserver.domain.net in the personal store on the local computer. Therefore, it is unable to support the STARTTLS SMTP verb for the connector External Mail Relay with a FQDN parameter of localserver.domain.net. If the connector's FQDN is not specified, the computer's FQDN is used. Verify the connector configuration and the installed certificates to make sure that there is a certificate with a domain name for that FQDN. If this certificate exists, run Enable-ExchangeCertificate -Services SMTP to make sure that the Microsoft Exchange Transport service has access to the certificate key.

However, the certificate in the personal store does have that name!
0
 
LVL 17

Expert Comment

by:James H
ID: 39662778
Are you load balancing between the two? What is the CAS Array address?
0
 
LVL 22

Expert Comment

by:Nick Rhode
ID: 39662784
What is the name on the cert.  Is it something like mail.domain.com?  Do you have an internal DNS record pointing to it so it would be something along the lines of https://mail.domain.com/owa?

You can verify your internal URL here:  http://www.windows-noob.com/forums/index.php?/topic/3611-how-to-configure-outlook-web-access-for-exchange-2007/
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 

Author Comment

by:ishamsi
ID: 39662806
Hi Spartan_1337, NLB isn't setup, no.

NRhode - The name on the cert is indeed mail.domain.com (the URL used for external OWA access is mail.domain.com/owa). There is no DNS record internally for mail.domain.com. I tried setting one up and can hit mail.domain.com internally after that, but I still get the same certificate error. The internal URL is https://servername/owa.

Does this help? As far as I can tell, the problem is with the certificate and the fact that the status says "invalid". And I guess the error in eventviewer backs this up. Just not sure where to go next with it...
0
 
LVL 9

Expert Comment

by:Frank McCourry
ID: 39662858
Your SSL certificate needs to include all names used for accessing your site.  Create an SSL certificate that has your outside and inside domain names.  A great tool for doing this is SelfSSL7.  Google it and you will find a dozen locations to download it.

there is a very good article about the process here: http://geekswithblogs.net/renewieldraaijer/archive/2011/05/11/self-signed-san-certificates.aspx
0
 

Author Comment

by:ishamsi
ID: 39662866
Hi,

The certificate already has all the names needed. External OWA address, internal server names, internal FQDN's etc.

As well as the common name it includes:

autodiscover.domain.com
autodiscover.domain.net
CASHT1
CASHT1.domain.net
CASHT2
CASHT2.domain.net
0
 
LVL 22

Expert Comment

by:Nick Rhode
ID: 39662911
Honestly the Internal URL should reflect the external URL and you would create an internal DNS record for this.  This way the certificate matches.  Typically I do not include the server name on my cert.  The problem is the certificate does not match the one installed.  The cert it is trying to connect to is most likely revoked or non-existent because you do have a legitimate certificate installed and assigned to the roles (SMTP, POP, IIS, etc).

Check this over to see if it helps.

http://support.microsoft.com/kb/555855
0
 

Author Comment

by:ishamsi
ID: 39662947
Hi NRhode,

Thanks for your post. What I now tried was adding a new zone for mail.domain.com into DNS and add a blank A record pointing to the HT/CA server. I pinged the name just to make sure. Then in EMC, I changed the internal URL to match the external URL. Now, when I browse to it, I still get the same error. Do you think the fact that get-exchangecertificate shows the status as "Invalid" has anything to do with it?
0
 
LVL 22

Expert Comment

by:Nick Rhode
ID: 39662983
After re-reading your problem this happened right after you updated the certificate because it was soon to expire.  Are you positive you assigned the new certificate to all the services required for your environment?  If anything try re-installing the certificate
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39664135
The TLS error is normal when you have been changing certificates around. Exchange requires a certificate with the server's real name on it for internal use.
The fix for that is to run

new-exchangecertificate

No switches or anything. You will get a prompt about replacing the default SMTP certificate. Accept the message and continue.

For everything else, reconfigure Exchange to use the external name internally.
http://semb.ee/hostnames

It is no longer best practise to include internal names on trusted SSL certificates, mainly because the SSL providers are going to stop issuing them from next year. Therefore switching to public FQDN is the best option.

Simon.
0
 

Accepted Solution

by:
ishamsi earned 0 total points
ID: 39770701
The ultimate cause of this was our ISA servers. Apologies I don't have a more detailed solution but it was resolved by a colleague. Ultimately I believe the new certificate had been applied to the Exchange boxes, but not the ISA. Thanks everyone for the suggestions.
0
 

Author Closing Comment

by:ishamsi
ID: 40063998
ISA servers. AGAIN.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The new Gmail Phishing Scam going around is surprising even the savviest of users with its sophisticated techniques.
A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question