KMS is not functioning properly

KMS(Key Management Service) is installed on one of Domain Controller but is is not functioning and clientmachines are showing windows need to update.
sanjayambreAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
LearnctxConnect With a Mentor EngineerCommented:
It looks like you have not activated enough clients with theKMS. Try running the following command:

Slmgr.vbs /dli

If the count is not higher than 5 you need to activate more hosts.

If the count is higher than 5, then try re-arming your end points, restarting them and then reactivating them.

Step 1: Re-arm by using command "slmgr.vbs -rearm"
Step 2: Reboot
Step 3: Activate "slmgr.vbs -ato"

If the count is higher than 5 make sure to check the key management service event log in eventvwr for any errors.

If you have Office bundled there is a good blog post here from Microsoft if you have not correctly sysprep'd the machines.

https://blogs.technet.com/b/odsupport/archive/2010/06/14/troubleshooting.aspx.
0
 
LearnctxEngineerCommented:
You have the KMS SRV records setup? Under the forward lookup in DNS for your domain this record should exist. _VLMCS._tcp.yourchild.yourrootdomain.internal.

DNS > Server > Forward Lookup Zones > yourchild.yourrootdomain.internal > _tcp

If it exists check the settings. You want to have it set to use port 1688 and point to the FQDN of your KMS server. Priority and all of that can be set to 0.

If it does not exist, create a new SRV record. Right click _tcp > choose other new records > service location (SRV).

Service: _VLMCS
Protocol: _tcp
Weight: 0
Priority: 0
Port: 1688
Host offering: yourkmsservername.yourchild.yourrootdomain.internal. << you want to terminate the FQDN with a period especially if you're servicing multiple domains.

In my case my KMS records all point back to a KMS server in the child domain of the forest.
0
 
sanjayambreAuthor Commented:
Checked & SRV settings are correct. we tried to update license on affected machines by running command "slmgr.vbs /ato" but geeting error.

Error is attached for the reference.
KMS-Error.jpg
0
All Courses

From novice to tech pro — start learning today.