Solved

tighvnc connection to ubuntu server refused

Posted on 2013-11-20
11
864 Views
Last Modified: 2013-11-27
I'm new to Ubuntu. I have built a LAMP server. Everything is working well except for my Remote connection to the server. Initially I was able to connect to the server using Tightvnc. But for some reason now my connection is being refused. I checked the ports that's listening and I don't see port 5900 in the list anymore. This was the port I was using to connect on. How can I get reconnected using tightvnc?
0
Comment
Question by:rraymond1130
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
11 Comments
 
LVL 19

Expert Comment

by:xterm
ID: 39664129
Please post the output of the following (2) commands:

ps ax | grep vnc

netstat -na | grep :590
0
 

Author Comment

by:rraymond1130
ID: 39664514
ps ax | grep vnc

10153 pts/1    S+     0:00 grep --color=auto vnc

 netstat -na | grep :590

"Nothing goes back to the command line"
0
 
LVL 19

Expert Comment

by:xterm
ID: 39664550
Okay, so the VNC server definitely isn't running - do you have a file /etc/init.d/vncserver?

If yes, please do:

  /etc/init.d/vncserver start

If you do not, please describe to me the steps you used to initially enable this service.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:rraymond1130
ID: 39664585
No I don't have that file. I did a search for desktop sharing and check all the options I needed and it worked for a couple of days.
0
 

Author Comment

by:rraymond1130
ID: 39664590
I just installed tightvncserver and when I run:
 vncserver - geometry 1024x768

I get this:

Couldn't start Xtightvnc; trying default font path.
Please set correct fontPath in the vncserver script.
Couldn't start Xtightvnc process.
0
 
LVL 19

Expert Comment

by:xterm
ID: 39664619
Try this, it seems to work out of the box for me:

  sudo apt-get install x11vnc

  x11vnc -nodpms -rfbauth -xkb /home/yourusername/.vnc/passwd -display :0


This is a better solution if you're trying to attach to a GUI which is already launched from bootup which sounds like you did.

By default it will die when you disconnect your VNC client session, but you can tweak the flags to have it stay up if that's what you desire.
0
 

Author Comment

by:rraymond1130
ID: 39666707
x11vnc -nodpms -rfbauth -xkb /home/myname/.vnc/passwd -display :0
** Results **

21/11/2013 13:14:29 passing arg to libvncserver: -rfbauth
21/11/2013 13:14:29 passing arg to libvncserver: /home/myname/.vnc/passwd
21/11/2013 13:14:29 x11vnc version: 0.9.12 lastmod: 2010-09-09  pid: 12828
No protocol specified
No protocol specified
21/11/2013 13:14:29 XOpenDisplay(":0") failed.
21/11/2013 13:14:29 Trying again with XAUTHLOCALHOSTNAME=localhost ...
No protocol specified
No protocol specified

21/11/2013 13:14:29 ***************************************
21/11/2013 13:14:29 *** XOpenDisplay failed (:0)

*** x11vnc was unable to open the X DISPLAY: ":0", it cannot continue.
*** There may be "Xlib:" error messages above with details about the failure.

Some tips and guidelines:

** An X server (the one you wish to view) must be running before x11vnc is
   started: x11vnc does not start the X server.  (however, see the -create
   option if that is what you really want).

** You must use -display <disp>, -OR- set and export your $DISPLAY
   environment variable to refer to the display of the desired X server.
 - Usually the display is simply ":0" (in fact x11vnc uses this if you forget
   to specify it), but in some multi-user situations it could be ":1", ":2",
   or even ":137".  Ask your administrator or a guru if you are having
   difficulty determining what your X DISPLAY is.

** Next, you need to have sufficient permissions (Xauthority)
   to connect to the X DISPLAY.   Here are some Tips:

 - Often, you just need to run x11vnc as the user logged into the X session.
   So make sure to be that user when you type x11vnc.
 - Being root is usually not enough because the incorrect MIT-MAGIC-COOKIE
   file may be accessed.  The cookie file contains the secret key that
   allows x11vnc to connect to the desired X DISPLAY.
 - You can explicitly indicate which MIT-MAGIC-COOKIE file should be used
   by the -auth option, e.g.:
       x11vnc -auth /home/someuser/.Xauthority -display :0
       x11vnc -auth /tmp/.gdmzndVlR -display :0
   you must have read permission for the auth file.
   See also '-auth guess' and '-findauth' discussed below.

** If NO ONE is logged into an X session yet, but there is a greeter login
   program like "gdm", "kdm", "xdm", or "dtlogin" running, you will need
   to find and use the raw display manager MIT-MAGIC-COOKIE file.
   Some examples for various display managers:

     gdm:     -auth /var/gdm/:0.Xauth
              -auth /var/lib/gdm/:0.Xauth
     kdm:     -auth /var/lib/kdm/A:0-crWk72
              -auth /var/run/xauth/A:0-crWk72
     xdm:     -auth /var/lib/xdm/authdir/authfiles/A:0-XQvaJk
     dtlogin: -auth /var/dt/A:0-UgaaXa

   Sometimes the command "ps wwwwaux | grep auth" can reveal the file location.

   Starting with x11vnc 0.9.9 you can have it try to guess by using:

              -auth guess

   (see also the x11vnc -findauth option.)

   Only root will have read permission for the file, and so x11vnc must be run
   as root (or copy it).  The random characters in the filenames will of course
   change and the directory the cookie file resides in is system dependent.

See also: http://www.karlrunge.com/x11vnc/faq.html
0
 
LVL 19

Expert Comment

by:xterm
ID: 39667919
Your Xorg graphical environment is no longer running, which explains why you weren't able to connect via the native method nor connect up x11vnc.

You will need to log into the console and run startx again (or just log in if it's sitting at a prompt)

After that, you will probably be able to connect without starting x11vnc or tightvncserver.
0
 

Author Comment

by:rraymond1130
ID: 39668768
OK this is what I get when I start startx. I hope this is the proper way to do it:

 startx


Fatal server error:
Server is already active for display 0
        If this server is no longer running, remove /tmp/.X0-lock
        and start again.


Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.

 ddxSigGiveUp: Closing log
Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyxinit: giving up
xinit: unable to connect to X server: Resource temporarily unavailable
xinit: server error
0
 

Accepted Solution

by:
rraymond1130 earned 0 total points
ID: 39669763
I found this Youtube video which helped me get RDP to work:
http://www.youtube.com/watch?v=KY3V79t5tKA
0
 

Author Closing Comment

by:rraymond1130
ID: 39680246
This helped resolve my issue
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question