Windows Server 2012 - Problems enabling Classic ASP website

I created a new website on Windows Server 2012, and I'd like to set the start page as index.asp
With index.htm is working fine, but my site is written in Classic ASP. How can I enable it on Windows Server 2012.
Thank you for your help
romsomAsked:
Who is Participating?
 
Scott Fell, EE MVEConnect With a Mentor DeveloperCommented:
Classic asp is not installed by default http://www.iis.net/learn/application-frameworks/running-classic-asp-applications-on-iis-7-and-iis-8/classic-asp-not-installed-by-default-on-iis and in addition you may want to turn on errors for development http://www.iis.net/learn/application-frameworks/running-classic-asp-applications-on-iis-7-and-iis-8/classic-asp-script-error-messages-no-longer-shown-in-web-browser-by-default

Lastly, you may be used to using server side includes like

<!--#include file="../folder/file.asp"-->

This will no longer work because parent paths are also turned off for security reasons.  While tempting to turn them on to make it easier for you, the better route is to be safer:

<!--#include virtual="/folder/file.asp"-->
0
 
romsomAuthor Commented:
Thanks for your reply. The problem is that in Windows 8 I cannot find any of these options. I was looking at other articles, but I simply can't find the solution.
0
 
romsomAuthor Commented:
Thank you very much, I found the solution in Windows 8 too.
0
 
Scott Fell, EE MVEDeveloperCommented:
>The problem is that in Windows 8 I cannot find any of these options

I am confused, you said server 2012.  The issue would be with iis.  Do you mean iis8?  The solution would be the same for iis7 and 8 in regards to turning on classic asp.

Did you get it working?
0
 
romsomAuthor Commented:
Yes, it's working now. You are right, IIS8
Thanks again.
0
All Courses

From novice to tech pro — start learning today.