[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 208
  • Last Modified:

Windows RDP

Hi,
    I was wondering if there is a way to connect to my office computer from home using Microsoft RDP without first establishing a VPN Connection.
0
Computers4me
Asked:
Computers4me
  • 7
  • 4
  • 2
  • +2
3 Solutions
 
Pramod UbheCommented:
for RDP, nope there is no option without any help like VPN.
There are some tools for taking control of remote desktop (screen sharing not RDP) but most of them require some input on target system before allowing screen sharing.

below is an example -

http://www.gotoassist.com/remote-support/
0
 
Computers4meAuthor Commented:
Ive been reading some things about rdp over internet rather vpn but nobody explains this in depth.
0
 
Pramod UbheCommented:
even if you manage to setup something, your company firewall will have blocking for 3389 port so I think it will be hardly possible.
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
Computers4meAuthor Commented:
Its the IT at the company I work for thats telling me this. They keep insisting that its an issue on my side. The say that they changed RDP listening port and sent me an rdp file with info already put in.
0
 
masnrockCommented:
Can you give us the info from the file? Maybe they did something wrong?
0
 
Computers4meAuthor Commented:
I spoke again with the IT person and he double checked the settings on the router and seems to be working now. He had said that he uses a static IP in the company which  is the address xxx.xxx.xxx.xxx:(Port #) to connect all employees to the network using straight RDP from windows rather then connecting using a VPN.
0
 
Computers4meAuthor Commented:
he just forwards the port numbers to the Specific Desktops in the company,
0
 
masnrockCommented:
Exactly, that's what supposed to be the case. But if your wasn't working for some time span, it could be that your office machine was either sleeping or turned off.
0
 
toddtelenickCommented:
Is your windows firewall turned on?  If they changed your listening port they also have to open that port in the firewall.
0
 
ktaczalaCommented:
What version of windows are you using at home?  Sounds like the IT dept has setup each office PC to listen for RDP on a different port than 3389, and setup their router to forward each port to a specific IP address at the company office. What version of windows server do they have at the office?
SBS 2008 & SBS2011 have RWW (Remote Web Workplace) which can allow RDP to Client PC's without having to fudge Ports on the router and workstations.
And yes it's possible that your Home PC is blocking the port you are using since it's not the default 3389. Either MS firewall or your Antivirus/security software.
Can you try to RDP to another employees Workstation? You don't need to login, but you should still get a login screen.
0
 
Computers4meAuthor Commented:
Im running on windows 7 Pro.

     I had no idea this was possible given the security risks of this method as aposed to a VPN layer. There is no server at workplace it is a small office consisting of about 15 employees. They are seting up evrything through a netgear router. They claim to have been doing it this way for over 10 years now.
0
 
ktaczalaCommented:
If you have that RDP file try it from a friends house on another PC, or from a laptop, or get a co-worker to try his at your house.
0
 
masnrockCommented:
What are the first two octects of the IP address? If the IP is a private IP, that will be an issue. If the firewall is not set to allow RDP connections from outside the network, that will be an issue too. Did your IT folks test from outside the network?
0
 
Computers4meAuthor Commented:
Whatever IT did it is working now. I am able to login now. In a test they conducted it was in collision with another computers port number. They changed the port number and seems to be working now.
0
 
Computers4meAuthor Commented:
Thanks for all the info. I really appreciate it.
0
 
masnrockCommented:
That would make sense. This is why documentation is so important!
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 7
  • 4
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now