Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 651
  • Last Modified:

.XLSB file in Windows 7 not loading on XLSTART

I just got upgraded to Windows 7 from Windows XP Professional.  In the past, I had a .xlsb file located in C:\Program Files\Microsoft Office\Office 14\XLSTART.  Each time I started Excel, this file would load as hidden and I had macros I was able to link to icons in my customized quick access toolbar.

Now that I have upgraded, I wish to be able to do the same.  I used the ? Application.StartUpPath in VBA Immediate Window to determine the new path which told me:  C:\users\*username*\AppData\Roaming\Microsoft\Excel\XLSTART\.

However, when I start Excel, it is not working.

Not sure what I am doing wrong.

Thanks!
0
mak345
Asked:
mak345
  • 3
1 Solution
 
Chris MillardCommented:
You might need to adjust the macro settings in the Excel trust-centre
0
 
mak345Author Commented:
Thanks, but I did enable all macro settings in the trust center.
0
 
mak345Author Commented:
Well, I was able to figure it out.  Basically, all I did was open the .xlsb file, hide it, and then link the macros to icons.  When I reopen Excel, and hit ALT-F11 to bring up VBA Editor, it does not appear that the macros are available.  This is why I thought it wasn't working.  However, when I actually click an icon, the macro runs, and I can then see the macro in VBA editor.  The workbook also stays hidden as I want it too.
0
 
mak345Author Commented:
Seems to work as expected.  I don't know why it doesn't show up in VBA when Excel starts, but it's there when I run a macro..
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now