Runtime Error

How can I fix error :

GfxUI.exe - .NET Framework Initialization Error
"Unable to find a version of the runtime to run this application."


Tried to install .NET Framework 4 , did NOT fix -


Thanks ,
LVL 4
mvalencia2003Asked:
Who is Participating?
 
jcimarronConnect With a Mentor Commented:
mvalencia2003--
I am no expert on .NET Framework, but I think it causes more confusion than any other topic.
Here is a MS thread on the message you are getting
http://answers.microsoft.com/en-us/windows/forum/windows_xp-performance/net-framework-initialization-errorunable-to-find-a/6ef76069-f481-48ad-ac30-d03e5c4d9638

This thread supposedly has an Answer.  
http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/gfxuiexe-net-framework-initialization-error-unable/0b2f3269-f03f-4dd7-9169-fd981a9079b6

I am not so sure, but try the troubleshooting procedure mentioned in the link offered.

http://support.microsoft.com/kb/929135#top
0
 
Paul JacksonSoftware EngineerCommented:
Go to  C:\Windows\Microsoft.NET\Framework\v0.0.0\config\ and change permissions for the file machine.conf for the Users group to Read & Execute
0
 
mvalencia2003Author Commented:
C:\Windows\Microsoft.NET\Framework

there is no v0.0.0

just :
v1.0.3705
v1.1.4322
v2.0.50727
v3.0
v3.5
v4.0.30319
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

 
Paul JacksonSoftware EngineerCommented:
Yes it depends on which frameworks you have installed, you just need to check the v4.0.30319 folder
0
 
Paul JacksonSoftware EngineerCommented:
Also you need to check the machine.conf file in the v2.0.50727\Config folder
0
 
mvalencia2003Author Commented:
USERS has read & execute permissions for machine.conf file ,
0
 
Paul JacksonSoftware EngineerCommented:
Have you updated any intel graphics drivers or hp drivers recently when did this problem start occurring?
0
 
Jacques Bourgeois (James Burger)Connect With a Mentor PresidentCommented:
Framework 4.0 does not use the same CLR (Common Language Runtime) as older versions, so application compiled for the previous versions of the framework won't work on a station that has only framework 4.0 installed.

You need to install framework 3.5 separately alongside 4.0.
0
 
mvalencia2003Author Commented:
One user doesn't get error , noticed in MSCONFIG - there is one start up service not there :
Dymo Label.

For the user getting the error , this service is there and checked.


Would this cause it?  How can it be fixed without unchecking it?
Thanks ,
0
 
Jacques Bourgeois (James Burger)Connect With a Mentor PresidentCommented:
The best way to know is to disable Dymo Label and see what happens.

If this corrects the problem, then you know it's the source of the problem.

The user might try to reinstall Dymo Label, which could reinstall the missing components.
0
 
mvalencia2003Author Commented:
Thanks ,
0
 
jcimarronCommented:
mvalencia2003--Glad to have helped.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.