Solved

How to Enable/Disable Multiple RDP Sessions in Windows 2012 R2

Posted on 2013-11-21
8
8,762 Views
Last Modified: 2013-11-21
How could i enable multiple sessions in Windows 2012 R2 session host server? When there is more than one collection available for a user i got this error and i think it is beacuse there is some standard restriction that only one session for a user, but where and how do i change this? The deployment has connection broker server, gateway server, rdweb access server and some session host servers.
"Another user of your computer is currently using this connection. This user must disconnect before you can log on."
0
Comment
Question by:per-w
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
8 Comments
 
LVL 3

Expert Comment

by:Chretien TALOM
ID: 39666524
Hi

By default, Windows 2012 servers allow a single Remote Desktop session. If only one session is available and you take over another person's live session, you may choose to enable multiple RDP sessions. This article describes the process for enabling and disabling multiple sessions.

Enable Multiple RDP Sessions

   -  Log into the server using Remote Desktop.
   - Open the start screen (press the Windows key) and type gpedit.msc and open it
   - Go to Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Connections.
   - Set Restrict Remote Desktop Services user to a single Remote Desktop Services session to Disabled.
   - Double click Limit number of connections and set the RD Maximum Connections allowed to 999999.

 Disable Multiple RDP Sessions

   -  Log into the server using Remote Desktop.
   -  Open the start menu and type 'gpedit.msc' and open it
   - Go to Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Connections.
   - Set Restrict Remote Desktop Services user to a single Remote Desktop Services session to Enabled.

Let me know if this solve your issue.

Thanks
Chretien
1
 

Author Comment

by:per-w
ID: 39666542
so its true that i have to do this from group policy? In 2008 there is a checkbox in configuration page. If i have 15 session host serveres, what group policy would i change on the domain controller to do this once?
0
 

Author Comment

by:per-w
ID: 39666582
should this be done on the connection broker? each user have only one connection to each session server. the problem is if there is 2 or more collections that a user have access to. The Administrator dont have the problem.
0
Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

 
LVL 3

Accepted Solution

by:
Chretien TALOM earned 500 total points
ID: 39666603
Hello my friend,

You need to perform this on the RDP server or on all your RPD server and that's all. Yes, it's normal that the admin do not have a problem :)

Thanks
Regards
0
 

Author Closing Comment

by:per-w
ID: 39666816
it works, but I want the option back in config window.
0
 
LVL 3

Expert Comment

by:Chretien TALOM
ID: 39666854
hi

I am glad that's work for you

Take care and feel free
Regards
Chretien
0
 

Author Comment

by:per-w
ID: 39666868
yes, its like Exchange 2013, the interface is simple and slow, why are they doing this? It looks nice, but i want function and not some fancy slow simple interface. Its like they want us to like slow fancy interface so its easier to use there slow cloud stuff like Office365 etc.
0
 
LVL 3

Expert Comment

by:Chretien TALOM
ID: 39666891
Yes,

I am an exch Admin and I really like exh13

all the best, regards

Chretien
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

OfficeMate Freezes on login or does not load after login credentials are input.
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
In this Micro Tutorial viewers will learn how to use Windows Server Backup to create full image of their system. Tutorial shows how to install Windows Server Backup Feature on Windows 2012R2 and how to configure scheduled Bare Metal Recovery backup.…
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…

635 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question