• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 234
  • Last Modified:

Linux lastb -t not filtering by time

This returns all results:
lastb -t 20131121103311

Open in new window

How can I get results only that are newer than the date specified?
0
hankknight
Asked:
hankknight
1 Solution
 
c_a_n_o_nCommented:
Not necessarily the answer, but maybe add a number to show like, show the last 10 up to that date.  
lastb -10 -t 20131121103311

Open in new window

0
 
hankknightAuthor Commented:
That is not helpful.  My question is regarding limiting results by date not by quantity.
0
 
simon3270Commented:
"lastb" (bad logins) doesn't take the "-t" parameter, only "last" (successful logins) does.

You can get what you want by using "last", but explicitly pointing it at the bad login file:
last -f /var/log/btmp -t 20131121103311

Open in new window

0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now