Win 8.1 task manager for standard user

Hi All. We are rolling out XPS 12's with Win 8.1 pro.
We have UAC set on the first notch from off.
When a user tries to run Task Manager, it prompts for an Admin Userid. We want them to run Task Manager.

I have searched for hours for a work around. I'm thinking there must be something in group policy, but don't see it.

Any help...

Thanks
yankeekAsked:
Who is Participating?
 
McKnifeCommented:
Very odd. Why is your vanilla different to mine?
About what to do: we can change the behavior by deploying a shim. It needs to set just one thing: "runasinvoker". Please read this for a how-to: http://blogs.technet.com/b/askperf/archive/2011/06/17/demystifying-shims-or-using-the-app-compat-toolkit-to-make-your-old-stuff-work-with-your-new-stuff.aspx

Edit: although I have used shims before, I am not sure if it works with any files, including system files like taskmgr.exe
0
 
McKnifeCommented:
Microsoft has made a strange decision here.
In order to start it, we have to insert our own username and password, not the admin's, one more time.
0
 
McKnifeCommented:
Wait... let me have another look. I remember it has been just as you describe it, but on a test machine (with UAC full on) it's just like with win7. Wait a minute.
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
McKnifeCommented:
Hmm... cannot reproduce it anymore. Has it been patched away? Do you run a fully updated machine?
0
 
McKnifeCommented:
0
 
yankeekAuthor Commented:
Hi all. The machine is fully patched. The user is not a local admin or domain admin. Just a standard user.
Re-entering their password does not resolve it. It keeps asking for credentials until a domain admin enters theirs..

Thanks though.
0
 
McKnifeCommented:
Ok, then let me tell you: I have an 8.1 x64 installation (pro, domain joined, no defaults changed, no software installed, naked system out of the box). If I use a standard user and start task manager, I get NO UAC prompt.

I don't know what's different at your side, but can at least say "yes, I have seen this before".
0
 
yankeekAuthor Commented:
Interesting McKnife..
We reburn each win8.1 from a vanilla image fully patched.
Any guess where the permission to run Task Manager might be in group policy? I dug around and didn't find it.
When searching the net to resolve, I did see that Task Manager and other utils have elevated privs to run. But never found a solution. It has to do with UAC. If UAC is turned off, then it runs fine. We can't have our users with UAC off by default.
Thanks for you input

Ken
0
 
yankeekAuthor Commented:
Well, this is still not resolved.

Thanks anyway..
0
 
McKnifeCommented:
Please be so kind to give proper feedback :)
I don't know whether you tried the shim or not.
0
 
yankeekAuthor Commented:
Using a shim is not going to be an option.
It's ok, we will have to figure something else out. I don't know why our vanilla burn is behaving like this if other vanilla burns are not. Maybe it will be addressed in an update down the road.

McKnife can have points. He was the only one to respond.

Thanks
0
 
McKnifeCommented:
Uh, why is the shimming no option, if I may ask? It's the least intrusive change there could be.
0
 
yankeekAuthor Commented:
Thank you McKnife. I think the techs resolved the issue if the UAC is set to the second notch up from off.

Please give McKnife the points. He was the only one to respond. He did supply a workaround but that will not be an option in our environment.

Thanks
Ken

(Thread can be closed).
0
 
McKnifeCommented:
Hi.

Please close the question yourself by selecting the most appropriate comment as an answer. Thanks and bye.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.